none
Visual Studio freezing when starting and wanting me to sign in (but of course I can't because it's frozen)

    Question

  • I had to do a System Restore, but now when I try to start Visual Studio and the window comes up, it freezes and I can't do anything (short of killing it in Task Manager). It also apparently wants me sign-in, which I can't do because it's frozen.
    Sunday, November 13, 2016 12:06 AM

All replies

  • Hi DragonOsman2,

    I'd like to ask you to:
    1. provide the version/build of your Windows and Visual Studio
    2. try to Run the System File Checker tool (SFC.exe)

    Regards,
    Ashidacchi
    Sunday, November 13, 2016 3:27 AM
  • Run devenv in /safemode and see if the problem persists.

    Also try logging all devenv activity to a file and see if there are any relevant messages.

    Sunday, November 13, 2016 3:43 AM
  • Hi DragonOsman2,

    Welcome to the MSDN forum.

    Sorry to trouble you and I just want to know does your issue is solved or not? Have you tried the solution that provided by Ashidacchi and Wyck?

    If this freeze issue persists, please have a try with the following to troubleshot:

    1. Open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run these commands as below, then open VS and see if the same issue will occur or not.
      • devenv /resetuserdata: clean up the user data
      • devenv /resetsettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.
    2. Run the VS as administrator, it can help us to excludes this possibility of the permission issue.
    3. Go to Control Panel—Programs and Features, right-click the VS item and Change-Repair, then open Vs again.

    If the above methods not work, please collect the log as Wyck said, it will help us to find the root cause of this issue, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, November 14, 2016 8:00 AM
    Moderator
  • Sorry for the late reply.

    It doesn't completely freeze anymore, but it does take time during start-up and seems to be frozen for a while (just not permanently - so I don't have to kill it with Task Manager). Should I still try the above-mentioned troubleshooting suggestions and see if they help?

    Wednesday, November 30, 2016 12:46 PM
  • Hi DragonOsman2,

    Thank you for your update.

    If this issue still troubles you and you can have a try with the above troubleshot steps when you have free time.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, December 1, 2016 9:50 AM
    Moderator
  • I'm sorry for troubling with a completely different question here, but what do you know about the "Bad Image" error encountered by VSIX Installer whenever I try to install extension in Visual Studio (I get an error message that mentions that, plus the clause that igdumdim32.dll is either corrupted or was not designed to run on Windows - I've searched for it in the designated PATH, but could only find igdumdim64.dll there and no igdumdim32.dll)?

    I've used a Media Creation Tool from Microsoft's support site to reinstall Windows 10, and I'll try doing that again after running DISM and sfc.exe.  If it still doesn't work, I'll try making a new thread to ask about it.  I'll try the methods you guys have provided for VS hanging for a bit on startup after that. 

    Monday, December 5, 2016 7:10 PM
  • Hi DragonOsman2,

    Since you have another issue about the installation of the extension, please navigate to this appropriate forum: https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=vssetup and start a new thread for your issue, you will get a more professional support from there, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 6, 2016 8:20 AM
    Moderator