locked
in local it doesnt work ... online it works ???? RRS feed

  • Question

  • User-2060258345 posted

    Hi,

    I've a silly issue, when i test my website on my lap ... in local even thought if I've removed every language in firefox conf, it doesnt work.

    When I copy my website with the same code online ... it works ...????, mystery mysteryyyy

    here is my website : http://onceuponatimejohanna.com/

    Thanks for your help :)

    Monday, February 8, 2010 1:01 PM

Answers

  • User1593168196 posted

    Does you IIS work properly ? Firewall?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 2:09 PM
  • User1983487377 posted

    hi..

     make sure you have configured IIS..

    then make sure the IIS service is  running... to restart IIS in run window try this command iisreset /restart

    then  finally check webconfig of your site....


    All the best 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 2:16 PM

All replies

  • User1593168196 posted

    Does you IIS work properly ? Firewall?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 2:09 PM
  • User1983487377 posted

    hi..

     make sure you have configured IIS..

    then make sure the IIS service is  running... to restart IIS in run window try this command iisreset /restart

    then  finally check webconfig of your site....


    All the best 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 2:16 PM
  • User-2060258345 posted

    I just check my iis configuration ...

    I've iis7 and globalization .NET is configurated like that :

    Culture : French (fr-FR)

    Enable Client Based Culture : True

    UI Culture : French (fr-FR)

    I've restarted it from IIS Manager but it still doesn't work ... it should come from there cuz my web.config works online :/

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- 
        Note: As an alternative to hand editing this file you can use the 
        web admin tool to configure settings for your application. Use
        the Website->Asp.Net Configuration option in Visual Studio.
        A full list of settings and comments can be found in 
        machine.config.comments usually located in 
        \Windows\Microsoft.Net\Framework\v2.x\Config 
    -->
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            </sectionGroup>
        </sectionGroup>
      </configSections>
      <appSettings>
    ...
      </appSettings>
    
      <connectionStrings>
    ...
      </connectionStrings>
    
      <!-- Only administrators are allowed to access OrderTest.aspx -->
      <location path="OrderTest.aspx">
        <system.web>
          <customErrors mode="Off" />
          <authorization>
            <allow roles="Administrators" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only existing customers can access OrderPlaced.aspx -->
      <location path="OrderPlaced.aspx">
        <system.web>
          <authorization>
            <allow roles="Customers" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only existing customers can access Checkout.aspx -->
      <location path="Checkout.aspx">
        <system.web>
          <authorization>
            <allow roles="Customers" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only existing customers can access CustomerDetails.aspx -->
      <location path="CustomerDetails.aspx">
        <system.web>
          <authorization>
            <allow roles="Customers" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only administrators are allowed to access CatalogAdmin.aspx -->
      <location path="CatalogAdmin.aspx">
        <system.web>
          <authorization>
            <allow roles="Administrators" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only administrators are allowed to access ShoppingCartAdmin.aspx -->
      <location path="ShoppingCartAdmin.aspx">
        <system.web>
          <authorization>
            <allow roles="Administrators" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <!-- Only administrators are allowed to access OrdersAdmin.aspx -->
      <location path="OrdersAdmin.aspx">
        <system.web>
          <authorization>
            <allow roles="Administrators" />
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
      <system.web>
        <roleManager enabled="true" />
        <identity impersonate="true" />
        <profile>
          <properties>
            <add name="CreditCard" type="System.String" />
            <add name="Address1" type="System.String" />
            <add name="Address2" type="System.String" />
            <add name="City" type="System.String" />
            <add name="Region" type="System.String" />
            <add name="PostalCode" type="System.String" />
            <add name="Country" type="System.String" />
            <add name="ShippingRegion" type="System.String" />
            <add name="DayPhone" type="System.String" />
            <add name="EvePhone" type="System.String" />
            <add name="MobPhone" type="System.String" />
          </properties>
        </profile>
        <membership>
          <providers>
            <remove name="AspNetSqlMembershipProvider" />
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web,Version=2.0.0.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" passwordAttemptWindow="10" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordStrengthRegularExpression="" />
          </providers>
        </membership>
        <compilation debug="true">
          <expressionBuilders>
            <add expressionPrefix="Themes" type="ThemesExpressionBuilder" />
          </expressionBuilders>
          <assemblies>
            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          </assemblies>
        </compilation>
        <authentication mode="Forms">
          <forms name="ChapeauShopLogin" loginUrl="Login.aspx" path="/" protection="All" timeout="60">
          </forms>
        </authentication>
    
        <pages styleSheetTheme="Magnolia">
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </controls>
        </pages>
        <anonymousIdentification enabled="true" />
        <customErrors mode="Off" />
        <globalization culture="fr-FR" enableClientBasedCulture="true" requestEncoding="utf-8" responseEncoding="utf-8" uiCulture="fr-FR" />
        <httpHandlers>
          <remove verb="*" path="*.asmx" />
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </httpHandlers>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </httpModules>
      </system.web>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="OptionInfer" value="true" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
        </compilers>
      </system.codedom>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules>
          <remove name="ScriptModule" />
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </modules>
        <handlers>
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </handlers>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
    




    Monday, February 8, 2010 3:26 PM