locked
RDP connection doesn't work in Windows 8.1. I can't connect remote server under Windows Server 2008 R2.

    Question

  • It always shows the error "because of protocol error this session will be disconnected".

    How can I resolve this?

    By the way, I already tried to uncheck Visual Styles and check/uncheck Persistent bitmap caching in RDP client properties. It doesn't work.

    I also tried changing group policies in Windows Server 2008 by enabling RDP compression. It doesn't work too.

    Friday, October 17, 2014 1:00 PM

Answers

All replies

  • 1.) Can you remote into any other machine using your app?

    2.) Can you remote into the problem machine using regular means - mstsc.exe?


    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog


    Saturday, October 18, 2014 1:32 AM
    Moderator
  • Hello.

    Thanks for your reply.

    1.I didn't try to remote any other machine since I have only one working server. But I connect successfully from other PCs to the same server.

    2. The same problem.

    I have 2 external IP addresses on the server. Remote Desktop connection is available for both of them. Could it be a reason?

    Saturday, October 18, 2014 4:05 PM
  • So how to fix it? Remote Desktop in Windows 8.1 works not correct!
    It's unbelievable, I can remote my server from Mac but I can't do it from Windows 8.1.

    • Edited by Xeim Monday, October 20, 2014 4:42 PM
    Monday, October 20, 2014 4:41 PM
  • Have you tried using the remote desktop app container sample: https://code.msdn.microsoft.com/Remote-Desktop-app-461567af ? Does that work?

    Have you tried using the Remote Desktop app: http://apps.microsoft.com/windows/en-us/app/remote-desktop/051f560e-5e9b-4dad-8b2e-fa5e0b05a480

    Does either of them work?

    Testing the above will tell you whether it is a programming error or an environmental issue.


    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Monday, October 20, 2014 4:46 PM
    Moderator
  • First one doesn't work - the same error.

    The 2nd one works with no errors.

    Tuesday, October 21, 2014 7:40 PM
  • Who can say me what this error means?

    Thursday, October 23, 2014 8:21 AM
  • Just wanted to say that it worked fine after I restarted the server. New Windows Update installed or smth else helped I don't know exactly.
    Sunday, October 26, 2014 7:48 AM