none
Crawl error on a fresh install RRS feed

  • Question

  • have a new MOSS 2007 install

    3 WFE's
    2 Search and 1 Index
    Windows 2008
    SQL 2005
    Moss is patches thru Dec 2008 Cumm.

    Farm is healthy no event log error.

    Added a site to test crawling/search and I get this in the Crawl Log 

    The system cannot find the path specified. (Exception from HRESULT: 0x80070003)

    There are also a total of 4 successful entries each stating its crawling the root site but only 1 entry for
    http: and sts3:

    Search on site returns nothing

    • Moved by Mike Walsh FIN Friday, March 20, 2009 6:37 AM search (crawl) q (Moved from SharePoint - Setup, Upgrade, Administration and Operation to SharePoint - Search)
    Wednesday, March 18, 2009 8:44 PM

Answers

  •  

    Hello,

     

    Please make sure that you have a gthrsvc folder in the Temp directory for the account running the search service and that the search service has proper access to it. If not, create the folder and set permissions correctly, then restart the Office SharePoint Server Search service.

    The gthrsvc folder will be located here: "drive: \Documents and Settings\<YourSearchAccountHere>\Local Settings\Temp\gthrsvc\"

     

    Regards,

    Jerry


    Xing-Bing Yu
    Friday, March 20, 2009 6:14 AM

All replies

  •  

    Hello,

     

    Please make sure that you have a gthrsvc folder in the Temp directory for the account running the search service and that the search service has proper access to it. If not, create the folder and set permissions correctly, then restart the Office SharePoint Server Search service.

    The gthrsvc folder will be located here: "drive: \Documents and Settings\<YourSearchAccountHere>\Local Settings\Temp\gthrsvc\"

     

    Regards,

    Jerry


    Xing-Bing Yu
    Friday, March 20, 2009 6:14 AM
  • Crawl questions go to the Search forum. Moving this.
    WSS FAQ sites: WSS 2.0: http://wssv2faq.mindsharp.com WSS 3.0 and MOSS 2007: http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles) http://wss.asaris.de/sites/walsh/Lists/WSSv3%20FAQ/V%20Books.aspx
    Friday, March 20, 2009 6:37 AM
  •  

    Hello,

     

    Please make sure that you have a gthrsvc folder in the Temp directory for the account running the search service and that the search service has proper access to it. If not, create the folder and set permissions correctly, then restart the Office SharePoint Server Search service.

    The gthrsvc folder will be located here: "drive: \Documents and Settings\<YourSearchAccountHere>\Local Settings\Temp\gthrsvc\"

     

    Regards,

    Jerry


    Xing-Bing Yu

    One other thing that i've found is, even with correct permissions the crawl still fails the next day. I had to place a deny all permission on for deleting the gthrsvc folder. When the the crawl failed I would find the folder once again missing, until I rebooted the server. Denying the folder from being deleted stopped that and the crawl works like a charm.
    Friday, July 24, 2009 1:23 PM