locked
/arch:ARMv7VE not working in RTM build

    Question

  • I have machine set, and tried to use this option to generate ARMv7 code with no luck.  I guess I'll fallback to the default, but when can I count on using the arch flag? The popup only lists SSE/2/3/AVX, but the docs say there are three settings for ARM builds.  I tried set this manually.  

    MachineARM (/MACHINE:ARM)

    Enable Enhanced Instruct Set   /arch:ARMv7VE

    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Microsoft.CppCommon.targets(347,5): error : Element <EnableEnhancedInstructionSet> has an invalid value of "/arch:ARMv7VE".


    Friday, September 7, 2012 8:46 PM

All replies

  • Hello,

    that switch seemed to work for me in a RTM build of VS 2012.  I right clicked on the project, properties.  In the property page dialog, changed the platform to ARM, expanded the node Configuration properties | C/C++, Command line, added the line /arch:ARMv7VE, clicked on OK, changed the active solution platform to ARM, selected Build | Build Solution.  I'll try to get additional info on why this isn't exposed widely.

    thanks!

    mike

    Saturday, September 8, 2012 12:21 AM
    Moderator
  • I didn't see any menu item for ARM architectures in the popup.  I'll try the command line, but having the "Enhanced Instruction Set" accurately reflect the platform would be helpful.  I thought the arch wasn't supported, because of the error message, so I fell back to "Not Set" to use the default.

    Saturday, September 8, 2012 7:30 PM