locked
Having trouble with HTTPWebRequest and proxy RRS feed

  • Question

  • User-316823630 posted

    Hi

    I am writing a simple console application which checks the status of a list if links.

    Basically we have a database full of URL's pointing at resources.  My console app simply loops through these, and checks the status of the link.  ie 404 not found, 302 moved etc.

    I am using the HttpWebRequest for this, and then using the resultant HttpWebResponse to get the status code.

    This all works fine, except there are some URLs which my HttpWebResponse returns as timed out, however the link works fine in a browser. (FireFox)

    I have since found that if I browse these URL's in Internet Explorer, the request is timing out and the site is not returned.  So Firefox is fine, and IE isnt.  After some digging I found that the HttpWebRequest uses the Proxy that is setup for IE.  So i tried looking at my proxy settings.... I dont have any.  I have tried setting the proxy on my HttpWebRequest to null, but that doesnt work also.

    So my question is, why cant IE and my HttpWebRequest browse to the URl successfully, but FireFox can?

    Thanks

    PaulTAG
     

    Sunday, March 4, 2007 6:21 PM

Answers

  • User113421904 posted

    Hi,

    Please check if "Automatically detect settings" is checked in IE -> Internet Option -> LAN Settings, and you can try manually setting the same proxy server as you did in other browsers.

    Hope this helps:

    http://support.microsoft.com/kb/135982

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, March 6, 2007 9:06 AM