none
Confusion about .Net Versions RRS feed

  • General discussion

  • Hi, I have to develop a transport agent for Exchange 2010 SP1. When I look at this http://technet.microsoft.com/en-us/library/ff728623.aspx it says that Exchange 2010 is supported again Frameworks 3.5 SP1 and 4 (if 4 is an upgrade of 3.5). No isses with that. But then I go to the sample http://msdn.microsoft.com/en-us/library/aa579828%28v=exchg.140%29 and it says "you must first install Visual Studio .NET 2005 and the Microsoft .NET Framework version 2 on the Hub Transport server". Whaaaaatt?? If I ignore the latter completely, develop on a dev machine using VS 2010, change the project to  .Net 3.5, fix a few missing references, it actually compiles fine. Would someone be so kind as to confirm that this dev method is OK? (I.e. just to ignore the latter link and assume it is way out of date?)

    TIA

    Mark

    Friday, July 13, 2012 6:29 PM

All replies

  • OK, after extensive testing, it appears that http://msdn.microsoft.com/en-us/library/aa579828%28v=exchg.140%29 is just plain wrong / outdated. It appears to work fine using VS 2010 and compiling to .Net 3.5.

    Sunday, July 15, 2012 4:03 PM