locked
Can not connect to configuration database(wss3.0) RRS feed

  • Question

  • After a server reboot, sharepoint gave up on me this evening, Everytime I try to browse to the sharepoint site I receive "can not connect to config database error".

    I thought that running psconfig -cmd upgrade -inplace b2b will help, but it failed in the first step, in the diagnostics log file, I keep seeing errors about connection failures. My central config site is also down, Therefore I checked the accounts in app pools, they seemed to be up and running, there's no password change on them. I am able to ping the remote database server, sqlserver service is up and running in the remote server and accepting remote connections, but when I create a udl file to connect to the sql server instance it simply fails to connect to oledb sql server instance.

    As a last option, I tried running sql server config wizard to detach the server from the farm and to reattach, After successfully completing detach, it failed when I tried to reattach to the server farm, it failed in the first step, where I typed in sql server db name and hit retrieve db names. Definitely looks like a connection problem but in the meanwhile eveything seems fine, I don't know what else I can check. Any suggestions??

    Monday, January 10, 2011 2:59 AM

Answers

  • No worries, It was a network issue, I added a static route between the server and other subnet where sql server resides and this fixed the problem.

    If any of you receive can not connect to conf database error, I would recommend:

    a) create an empty text file and saving it with extension udl. 

    b) open the file

    c) click on providers

    d) select oledb sqlserver

    e) click on connection tab

    f) enter server name, select credential type and enter credentials if necessary hit refresh, and try to see database names

    These steps prove if you are able to connect to sql server instance in the remote computer.

     

    Monday, January 10, 2011 4:12 AM