none
Problem with Running Excel Add-In

    Question

  • I have tried to run an Excel Add-in solution from the Office 365 web site (Task Pane Add-in Sample - Excel). This program ran fine on VS2015 before Update 1. Now, the sdk for this is apparently missing for the updated version, as the solution explorer shows that it is unavailable. There is a selection in the solution explorer to "Install Missing Features". When this is selected, the system attempts to run setup, but does not install the feature. Instead, an error message pops up telling you that you must close VS2015 to continue, but there is no "continue" button, so you can't close it and continue. It's a "Catch 22".

    After installing the update, the are no Office templates or any mention of Office development in the New Project start-up screen.

    Steve


    Steve Hunt

    Wednesday, January 13, 2016 5:05 PM

Answers

All replies

  • Hi Steve,

    According to your description, this issue is related to VS 2015 update 1, the VS General forum is the better place for this issue and we will move it there for you.

    Regards

    Starain


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 14, 2016 8:17 AM
    Moderator
  • Hi Steve,

    Which version of Visual Studio 2015 are you using? I also can't find the Office templates in my Visual Studio 2015 Community version with Update 1, but it can been found in Visual Studio 2015 Enterprise version with Update 1.

    If you are using Visual Studio 2015 Community, please install Office Developer tools for Visual Studio 2015 from below link and then please try create a new office project again.

    If you are using Visual Studio 2015 Enterprise, please check from Control Panel -> Programs and Features -> Visual Studio 2015 Enterprise -> Change -> Modify, whether you have checked the "Microsoft Office Developer Tools". If not, please check and update it.

    If you have checked, please try repair your Visual Studio and then please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,
    Weiwei

    Friday, January 15, 2016 5:32 AM
    Moderator
  • Weiwei

    I'm running VS2015 Community Edition.

    On your reply you wrote:

    "If you are using Visual Studio 2015 Community, please install Office Developer tools for Visual Studio 2015 from below link and then please try create a new office project again."

    What link are you referring to for the download? I don't see it in your reply.

    Thanks,

    Steve


    Steve Hunt

    Friday, January 15, 2016 3:53 PM
  • Weiwei

    Here is the link to the VSLog file:

    https://onedrive.live.com/redir?resid=4789D247CD49B68B!6448&authkey=!AGM1n2shQcka__Y&ithint=file%2czip

    Thanks


    Steve Hunt


    • Edited by Oldpivot2 Friday, January 15, 2016 7:01 PM
    Friday, January 15, 2016 6:59 PM
  • Hi Oldpivot2,

    Sorry for forgetting past the download link in my reply. Please download Office Developer tools for Visual Studio 2015 from this link.

    https://www.visualstudio.com/en-us/features/office-tools-vs.aspx

    And according to your installation log, I don't find errors about Office Developer tools. So please install the tools first and check whether it will works fine.

    Best Regards,
    Weiwei

    Monday, January 18, 2016 1:34 AM
    Moderator
  • Weiwei,

    I installed the tools from the link above and everything is now working fine as far as I have been able to test it.

    Thank you for your help!

    Steve


    Steve Hunt

    Monday, January 18, 2016 10:28 PM
  • Hi Oldpivot2,

    I'm glad that you have resolve your problem. Please mark the helpful reply as answer, which is benefit to other communities who has the same problem.

    If any questions about Visual Studio IDE in future, please feel free to come back to our forum.

    Best Regards,
    Weiwei

    Tuesday, January 19, 2016 1:16 AM
    Moderator