locked
Using a Java Binding Library still requires .jar to be added to application project RRS feed

  • Question

  • User221 posted

    In the Mono for Android documentation for Binding a Java Library, it states

    Prior to Mono for Android 4.2.8, it is necessary to embed the .jar files in the Mono for Android application project. Starting in Mono for Android 4.2.8 this step is no longer required. Mono for Android projects just need to reference the assembly for the Java Biding[sic] Library.

    I have found this is not the case. I am using Mono for Android 4.4.54 and I still need to add the binding .jar to the application project as AndroidJavaLibrary. If I do not add the .jar to the application project, I get a build error stating it cannot find the java package.

    Am I doing something wrong (it's the first time I've used a Java Binding Library) or has there been a regression?

    Friday, January 4, 2013 1:28 PM

All replies

  • User35 posted

    @sly - I just tried this out in 4.4.54 myself, and can confirm the behaviour you're seeing. This seems like a regression to me, so I've logged this as bug 9271.

    Friday, January 4, 2013 5:20 PM
  • User1310 posted

    I don't seem to have this issue. I'm wrapping AChartEngine, just downloaded the latest update (4.4.54), and rebuilt the wrapper - it works as specified for me. All I have is the wrapper and a reference to the jar in my wrapper dll.

    Saturday, January 5, 2013 12:50 AM
  • User356 posted

    For what it's worth I am not having the issue either. Just upgraded to 4.4.54 and opened an old version of a project that I am working on that referenced a java binding lib (zebra printer sdk) - deleted the jar and it still worked as before. Also bug # 6695 does not appear to have been fixed as indicated (in bugzilla) - at least for me. This doesn't affect any current builds that I am working with as I am now referencing the dll rather than the project itself as suggested in the documentation.

    Saturday, January 5, 2013 4:12 AM
  • User221 posted

    It appears that the binding library project must use EmbeddedJar instead of InputJar now. This is missing from the documentation for creating a binding library.

    Saturday, January 5, 2013 11:12 AM
  • User6897 posted

    I am using embeddedJar and things are good, but some methods like ZebraPrinterConnection and ZebraPrinter are not found. Is there another jar file that i need to bind to use the ZEBRA printer?

    Thursday, August 29, 2013 10:05 AM