locked
Form not getting activated RRS feed

  • Question

  • Hi,

    I am trying to activate the .xsn infopath path form in the Central Admin server and I am getting the below error.

    'The form template could not be activated to the site collection. You do not have the permissions required to perform this operation. Only the administrators of this site collection can activate to the site collection. Either add yourself as a site collection administrator, or have a site collection administrator activate the form template.'

    Other information:

    - Have uploaded the form successfully to the farm.

    - User is the primary site collection administrator and also the Site collection administrator(site collection level)

    - Tried to activate throught the site settings and end up in recieving the same error message above.

    Please help on this.


    Shameej
    Saturday, August 13, 2011 3:00 PM

Answers

  • Hi Shameej ,

     

    I understand that you want to activate a info path form template in Central Administration . It prompt an error stating that you don’t have permission while you are the administrator of the site collection .Have you tried to activate the template using stsadm.exe? You can try this by doing :

    1.       Open the Command Prompt and change the path to C:\Program Files\Common Files\Microsoft Shared\web server extension\12\BIN .

    2.       Run stsadm.exe -o ActivateFormTemplate -url "http://suppliers.odomcorp.com" -filename "C:\Dana Share\NewItemForm.xsn” (change the url and the file name to meet  your requirement )

     

    Thanks,


    Entan Ming
    • Marked as answer by shameej Wednesday, August 17, 2011 6:10 AM
    Monday, August 15, 2011 10:35 AM
    Moderator
  • Yes I tried stsadm.exe and it's working !!

    Entan, there is a slight change in the stsadm command though, the former gave me the same error. Below is what I tried and worked.

    stsdm -o activatefeature -name FT-02-9h324347-6674-9068-3db3-a97f4436fdf34 -url <url> -force

    Note: Any reason why I can't activate the infopath like the normal way we do. Tried with Site Collection Admin, Primary site collection admin and Farm admin too...


    Shameej
    • Marked as answer by shameej Wednesday, August 17, 2011 6:10 AM
    Wednesday, August 17, 2011 6:10 AM
  • Note: Any reason why I can't activate the infopath like the normal way we do. Tried with Site Collection Admin, Primary site collection admin and Farm admin too...


    Shameej


    I have the same issue on a server on a client's site. They have two farms (UAT and Live). It works fine via Central Administration on the UAT farm, but we get the same issue on the Live server (i.e. must use stsadm to upgrade/activate).

    I believe the issue is due to some group policy setting applied to the Live server but not the UAT, there are more restrictive policies applied to the Live server (for e.g. I can't run many .exe files on it). I haven't tried to chase down the exact policy causing the issue yet, because I have a workaround and I'd prefer to change as little possible on a live site, but if you want to track it down that's where I'd start.

    • Marked as answer by shameej Thursday, August 18, 2011 4:08 PM
    Wednesday, August 17, 2011 2:59 PM

All replies

  • Any update or suggestion on this?


    Shameej
    Sunday, August 14, 2011 6:24 AM
  • Hi Shameej ,

     

    I understand that you want to activate a info path form template in Central Administration . It prompt an error stating that you don’t have permission while you are the administrator of the site collection .Have you tried to activate the template using stsadm.exe? You can try this by doing :

    1.       Open the Command Prompt and change the path to C:\Program Files\Common Files\Microsoft Shared\web server extension\12\BIN .

    2.       Run stsadm.exe -o ActivateFormTemplate -url "http://suppliers.odomcorp.com" -filename "C:\Dana Share\NewItemForm.xsn” (change the url and the file name to meet  your requirement )

     

    Thanks,


    Entan Ming
    • Marked as answer by shameej Wednesday, August 17, 2011 6:10 AM
    Monday, August 15, 2011 10:35 AM
    Moderator
  • Yes I tried stsadm.exe and it's working !!

    Entan, there is a slight change in the stsadm command though, the former gave me the same error. Below is what I tried and worked.

    stsdm -o activatefeature -name FT-02-9h324347-6674-9068-3db3-a97f4436fdf34 -url <url> -force

    Note: Any reason why I can't activate the infopath like the normal way we do. Tried with Site Collection Admin, Primary site collection admin and Farm admin too...


    Shameej
    • Marked as answer by shameej Wednesday, August 17, 2011 6:10 AM
    Wednesday, August 17, 2011 6:10 AM
  • Note: Any reason why I can't activate the infopath like the normal way we do. Tried with Site Collection Admin, Primary site collection admin and Farm admin too...


    Shameej


    I have the same issue on a server on a client's site. They have two farms (UAT and Live). It works fine via Central Administration on the UAT farm, but we get the same issue on the Live server (i.e. must use stsadm to upgrade/activate).

    I believe the issue is due to some group policy setting applied to the Live server but not the UAT, there are more restrictive policies applied to the Live server (for e.g. I can't run many .exe files on it). I haven't tried to chase down the exact policy causing the issue yet, because I have a workaround and I'd prefer to change as little possible on a live site, but if you want to track it down that's where I'd start.

    • Marked as answer by shameej Thursday, August 18, 2011 4:08 PM
    Wednesday, August 17, 2011 2:59 PM
  • Thanks... That was informative Steven.
    Shameej
    Thursday, August 18, 2011 4:08 PM
  • I go to Site Settings > Site Features  > Site Collection Features 

    And activate the Form pressing the Activate button.


    Thursday, February 7, 2013 10:34 PM