none
SSMS 2016: Syntax-Highlighting is not working properly

    Question

  • I just installed SSMS 2016. Everything is working fine now - except the syntax-highlighting.

    As you can see, the syntax-highlighting is working only partially (GETUTCDATE should be pink, the string should be red, the sys-table should be green).

    Unfortunately, the color-settings do look perfectly fine. E.g.:

    What can I do to get this working?

    Any ideas?

    I did already reinstall it without any effect.

    BTW: Even though I downloaded the installer for English, it somehow ended up with mixed languages in the UI. Following the link in the options, I tried to download the package for English. While installing it, I got the error-message, that VS 2015 is not installed on the machine. This is very true, since I use VS 2017.



    • Edited by Asopos Tuesday, April 04, 2017 10:01 PM
    Tuesday, April 04, 2017 9:56 PM

Answers

All replies

  • I have checked your settings and they do look correct. What version of SSMS are you running? I am running 14.0.16000.64
    Tuesday, April 04, 2017 11:08 PM
  • Thank you for checking.

    I am using a newer version:

    Wednesday, April 05, 2017 6:29 AM
  • Hi Asopos,
    Does the issue still exists after you install the new version of SSMS ?Please let me know.
     
     
    Hope it can be helpful
    Regards,
    Davy

    MSDN Community Support<br/> Please remember to click &quot;Mark as Answer&quot; the responses that resolved your issue, and to click &quot;Unmark as Answer&quot; if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact <a href="mailto:MSDNFSF@microsoft.com">MSDNFSF@microsoft.com</a>.

    Thursday, April 06, 2017 12:38 AM
  • Hi,

    as far as I can see, I do have the most recent version.

    At least according to this page, the most recent version is "13.0.16106.4", which is exactly the version from my screenshot.

    Is there anything newer I can get?

    Regards

    Andreas

    Friday, April 07, 2017 1:55 PM
    • Marked as answer by Asopos Friday, April 07, 2017 2:53 PM
    Friday, April 07, 2017 2:36 PM
  • Using 2017 RC3 did help.

    Thank you!

    Friday, April 07, 2017 2:54 PM
  • The issue returned :-(

    SSMS reported an update and I installed it. Now I am using SSMS 17.0 (no "RC" anymore") and the colors are gone again.

    Wednesday, May 17, 2017 1:42 PM
  • One little trace: If I logon using a different user, highlighting works perfectly fine.

    Deleting

    AppData\Roaming\Microsoft\SQL Server Management Studio

    and 

    AppData\Local\Microsoft\SQL Server Management Studio

    did not help.

    Any other ideas?

    Wednesday, May 17, 2017 3:24 PM
  • Did you try the use defaults button? I am not sure what this is in German (I believe your management studio is German - correct)?
    Wednesday, May 17, 2017 3:57 PM
  • Did you try the use defaults button? I am not sure what this is in German (I believe your management studio is German - correct)?

    I am not sure, which function you mean. I tried Tools -> Import and Export Settings -> reset everything.

    It finished with two messages that should not matter. Translated from German:

    "The settings were reset with some errors.

    Warning 1: Did not find "Debug.ParallelTasks". The keyboard-shortcut was not reset.

    Error 1: Error while importing the settings for "List for external tools" [Code 5611]."

    This did not help unfortunately (even after a restart).

    About the language: I tried my best to get an installation in english. It's not as easy as it sounds and currently, it is a strange mix between German and English.

    Thursday, May 18, 2017 10:32 AM
  • For the sake of completeness: I ended up deleting my user-profile on the machine (just the profile, not the user).

    Doing this, I lost most configurations in applications, browser-profiles, etc.

    But the syntax-highlighting in SSMS does finally work again.

    Friday, June 09, 2017 9:56 AM
  • With the latest update of SSMS, the issue returned again :(

    But now, all the colors are gone.

    • Edited by Asopos Monday, January 08, 2018 8:30 AM
    Monday, January 08, 2018 8:29 AM
  • With the latest update of SSMS, the issue returned again :(

    But now, all the colors are gone.

    Same issue to me :( 

    It's like only for string object highlight doesn't work properly 

    • Edited by Panilo Wednesday, February 07, 2018 7:15 PM
    Wednesday, February 07, 2018 7:09 PM
  • UPDATE 

    Got it! Finally I installed the ITA MSSQL Studio and highlight seem to work (I've also windows in ITA, I know I must use EN but I would like to try Cortana...). The problem seem to appear only if u have windows installed in another language than MSSQL Studio 

    Friday, February 09, 2018 2:48 PM
  • Hi,

    we faced the same issue after installing SSMS 17.6 on one of our Terminal Servers.

    We have a Win2016 Server with german Language.

    Possible Cause:

    Office 2013 with English Version.

    Installed SSMS 17.6 accidently with german language Version.

    (our users used ssms, so some informations were wrote to user profiles i guess)

    Changed Office Language from english to german because of user requirements.

    We reinstalled  SSMS 17.6 with english Version.

    Problem:

    Syntax highlighting didn't work anymore.

    Solution:

    After logging off the users and deleting their user Profile under C:\User\<userprof>

    and relogging in to Server this issue with sysntax highlighting was gone.

    Hope that helps maybe also others :)

    Cheers & happy bug tracking.Roland


    Friday, April 13, 2018 8:59 AM