Usage on internal web applications RRS feed

  • Question

  • Hi,

    I have created a small sample web application that uses the most basic Application Insights telemetry. This works fine when I run the application locally on my dev machine at home. However, if I connect to my company VPN or if I run the same application on a server inside the company network then no AI data is being sent to the dashboard. When I look in the output window in VS I see entries like ...

    Application Insights Telemetry: Server Analytics data upload to the Application Insights service failed. The data has been written to a file and the data upload will be tried again.

    The data never does get sent. As I said, it works fine if I disconnect my VPN and run the application locally.

    That leads me to believe that AI must be using something other than HTTP to send the telemetry data. Could you please explain why this might fail and, if appropriate, which ports/mechanism are used. Any more information on this problem would be gratefully received as I would really like to investigate the potential of AI.



    Friday, April 4, 2014 8:59 AM


  • Hello Steve,

    F5 debugging sends data to f5.services.visualstudio.com, deployed app sends data to dc.services.visualstudio.com, both utilize HTTPs (443) channels. It very well might be a proxy issue or firewall issues in the network. (You can validate the URLs with Fiddler to be sure).

    Take a look if some outgoing requests are blocked and then you may find a rule to change in proxy/firewall.

    Dmitry Matveev

    Tuesday, February 10, 2015 7:42 PM