locked
Workflow issues with look up column from root site or other site RRS feed

  • Question

  • Hi,

    I have following scenario:

    Sharepoint 2013 online (Office 365).

    Home site With a list, let's Call it list A.

    Have a subsite let's Call it for sub-site A.

    Have a list (let's Call it for sub-site-list) in this site which use list A as look up.

    Created a workflow which will send e-mail.

    My issue is if I try to fetch the value the value from this look up column (I try to fetch value as i do With other column) i sub-site-list, than the workflow With stop/hang. It seems that it try  to send a REST Call for some column that is not exists.

    Appreciated for any respond.

    Friday, October 31, 2014 12:26 PM

Answers

  • Hi,

    According to your post, my understanding is that you can’t get the value of cross site lookup column in a SharePoint Online list workflow.

    In my SharePoint Online, I also do this test and I get the same result as yours. While cross site lookup columns work in a web browser, cross site lookup fields are not supported in a SharePoint Designer workflow.

    The problem occurs because SharePoint Online doesn’t support Server Side Object Model REST service. In addition, I find a possible workaround for your reference. Please check Shai.Petel’s reply in this thread for more information.

    You can try this App in the SharePoint O365 store, it should allow you to create cross-site lookup fields:

    office.microsoft.com/.../kwizcom-cascading-lookapp-WA104116641.aspx

    Here is a similar thread as below for your reference:

    http://community.office365.com/en-us/f/154/t/224133.aspx

    As this question is more relate to SharePoint Online, I suggest you can post it to the Office 365 forum, you will get more help and confirmed answers from there.

    http://community.office365.com/en-us/forums/default.aspx

    Best Regards,

    Yumi Fu

    • Marked as answer by Lindali Friday, November 7, 2014 8:26 AM
    Monday, November 3, 2014 9:21 AM