none
Can't Install .NET Framework 4 - Win Vista 64-bit RRS feed

  • Question

  • I have been at this and I have not managed to find a solution to this. My .NET Framework was having problems so I decided to uninstall all of them from control panel and try re-installing. That didn't work so I tried everything on this thread: http://social.msdn.microsoft.com/Forums/eu/netfxsetup/thread/18c1b6a5-c0d3-4e2f-8ec7-9192d23cb45c, and absolutely nothing worked.

    Logs: https://skydrive.live.com/redir?resid=6A40F4068BF23D0E!146&authkey=!AMQml4l6vOHLITo

    What can I do?



    OS Version = 6.0.6002, Platform 2, Service Pack 2
    OS Description = Vista - x64 Home Premium Edition Service Pack 2
    CommandLine = C:\e7b2eb32d9d20d385a7be7c7a5c7ba6b\\Setup.exe /x86 /x64
    TimeZone = Pacific Daylight Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 12
    Exe (C:\e7b2eb32d9d20d385a7be7c7a5c7ba6b\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\e7b2eb32d9d20d385a7be7c7a5c7ba6b\Windows6.0-KB956250-v6001-x64.msu) failed with 0x80080005 - Server execution failed .
    Final Result: Installation failed with error code: (0x80080005), "Server execution failed " (Elapsed time: 0 00:08:16).






    • Edited by Kodak- Saturday, May 19, 2012 3:34 AM
    Saturday, May 19, 2012 2:38 AM

Answers

All replies

  • You appear to be using the web installer.

    The failure is here:

    "Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.0-KB956250-v6001-x64.msu) failed with 0x80080005 - Server execution failed .
     PerformOperation on exe returned exit code 2148007941 (translates to HRESULT = 0x80080005)"

    Please use the standalone installer, following these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by TZSA_M Tuesday, October 18, 2016 8:38 AM
    Saturday, May 19, 2012 2:14 PM
  • This is the only part I am quite confused about:

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    You'll have to forgive me for my lack of knowledge. What exactly do I input inside the cmd prompt? I entered "dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d" the last line said file not found. I don't know if this was for one of the hundreds of files or just the last one.




    • Edited by Kodak- Saturday, May 19, 2012 4:26 PM
    Saturday, May 19, 2012 4:05 PM
  • Start Orb-> All Programs-> Accessories.

    One of the accessories is Command Prompt. Right click on Command Prompt, then select Run As Administrator to open.

    Paste the command given:

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T

    at the prompt itself, then hit Enter.

    Note: to paste into the Command Window, click the icon at the left ot the title bar to open the menu. Select Edit->Paste.

    Saturday, May 19, 2012 5:25 PM
  • Alright I did so, and again the installation failed. 

    Logs: https://skydrive.live.com/redir?resid=6A40F4068BF23D0E!147&authkey=!AFUjBW3gDSWR13M

    I'm so confused on why this could be happening. 


    • Edited by Kodak- Saturday, May 19, 2012 6:33 PM
    Saturday, May 19, 2012 6:33 PM
  • Unfortunately, the error remains the same.

    I recommend you repair your Vista. For help with that, here are the correct forums:

    http://answers.microsoft.com/en-us/windows/forum/windows_vista

    Alternatively, we can hope somebody else will jump into the thread and offer a second opinion.

    Saturday, May 19, 2012 8:33 PM
  • I'm confused on what's causing the problem :/

    Is there a way I can manually do something to get rid of it instead of having cmd do it?

    Saturday, May 19, 2012 9:36 PM
  • Get rid of what? I thought you'd " uninstall all of them from control panel and try re-installing."

    As you have Vista, you cannot get rid of the embedded .NET Frameworks that came as part of your OS (2.0 and 3.0).

    Are you saying that you think you did not successfully uninstall .NET Framework 4.0?

    You can run this verification tool to find out what .NET Frameworks are on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    As to what's causing the problem, I suspect some level of OS corruption. That's why I suggested OS repair.

    Saturday, May 19, 2012 11:41 PM
  • Oh nevermind, I thought the command was getting rid of something.

    And honestly, I would believe that my OS is corrupt at some level, because of how many problems and errors I face. My audio drivers haven't been working for 6 months now and anything I've tried doesn't work. It's been pretty annoying not having any sound. 

    But backing up 400GB of data isn't really the most joyful thing to do. I wouldn't know where to start to be honest.

    Oh and the program showed I only have 2.0 and 3.0.
    • Edited by Kodak- Sunday, May 20, 2012 3:15 AM
    Sunday, May 20, 2012 3:13 AM
  • Hi Kodak-,

    Welcome to the MSDN forum.

    Your error 0x80080005 always means that you are using out of process COM server. I referred to this blog http://support.microsoft.com/kb/825118

    I may have to say this error is hard for us to fix, could you please refer to this page and try that solution:

    http://blogs.technet.com/b/asiasupp/archive/2011/08/29/windows-update-wsus-failed-with-error-0x80080005-try-this-solution.aspx

    If error still exist, I may have to say that you really have to reinstall or repair your OS.

    You said that you have 400GB of data, the size is really huge. I suggest you divide your hard disk with more than one disk space and use only one of it to install your OS next time. As far as I know, reinstall the OS will only overwrite that specific disk. So you won't have so much data to be backup.(What's more, to backup your OS is a good habit to save your time.)

    Thanks for understanding.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    Monday, May 21, 2012 8:35 AM
    Moderator