none
Exchange 2007 Out of Office Certificate Error RRS feed

  • Question

  • Hello,

    I have an Exchange 2007 Server and for some odd reason this week, we have been having issues enabling Out of Office in Outlook. It is some sort of issue with the Autodiscover service, but despite reading forum post after forum post, nothing has worked for me. At first when we would go into Outlook and click on Out of Office, it would freeze and then say the server is unavailable. I realized that it was trying to resolve a URL so I added a manual A record in the DNS server pointing to the local IP of the server and it fixed the issue, kind of. Now when we click on Out of Office Assistant, we get a security certificate error and it is driving my users crazy. I have updated the SRV record and many things, still unable to get it to work. 

    Any help would be super!! 

    Thanks!

    Thursday, September 25, 2014 5:37 PM

All replies

  • hi jonatha,.. this is a typical autodiscover issue which i once got with ex 2010. sorry but i havent worked on 2007 so i can guide you to below two links which are talking almost same as you have mentioned

    http://social.technet.microsoft.com/Forums/office/en-US/d632b96a-ea9b-4e2f-9128-64f73083f56d/unable-to-set-out-of-office-since-renewing-exchange-2007-ssl-certificates?forum=exchangesvrclientslegacy

    http://social.technet.microsoft.com/Forums/office/en-US/94c5828f-07ab-4646-a551-6c4cf868d2d9/exchange-2010-out-of-office-error?forum=exchange2010


    MARK AS USEFUL/ANSWER IF IT DID


    Thanks
    Happiness Always
    Jatin

    Thursday, September 25, 2014 6:00 PM
  • I have already tried those and they did not work. 
    Thursday, September 25, 2014 6:30 PM
  • Hi,

    1.First of all please check the name what you are using for autodiscover service is available on SAN certificate.

    2.Please check the name resolution is happening for autodiscover namespace.

    I.e if you try to resolve autodisccover.mydomain.com (or) mail.mydomain.com in your problematic PC it should have to resolved in to cas server ip address or in some scenarios it will get resolved in to LB

    3.Then please check whether you have properly set the autodiscover internal URL in all the cas servers.

    It might be like below

     https:\\autodiscover.mydomain.com\autodiscover\autodiscover.xml

    (or)  

    https:\\mail.mydomain.com\autodiscover\autodiscover.xml

    4.Then please check for the web services url in all the cas servers and that is the major thing which will make the availability services (i.e OOF,free busy lookup) to work perfectly .

    5.In the problematic please uncheck the internet proxy exceptions.

    6.You cane use test email configuration to check whether the outlook client is fetching up the proper url for autodisocver and ews .

    7.test-outlookwebservices (we can use this command to check the fuctionality of autodiscover for an problematic user account)

    8.Please check the root certificates in the problematic client to check whether it is a expired or not .Root certificates is nothing but the one which will come by default with OS .

    9.If all the above is set as perfect but still you are facing the issue.Please follow the below one and this may be not required.

    Please export the san certificate from exchnage to pfx file which should have to include the certificate key by using MMC.Then import the pfx file in to problematic client .Let us see what happens .

    Same on my side i am having few questions about your environment .

    1.Are you facing any certificate errors in OWA .Because why i am asking please check the installed SAN certificate in exchange is valid and or it is not expired ?

    2.what is the problematic client operating system veriosn?

    Please reply me if you have any issues .

    Regards

    S.Nithyanandham

    Thursday, September 25, 2014 7:04 PM
  • I think I tried everything you posted, but putting so much info in one reply, it was hard to cover it all... I am still having the issue. The users connect to a Windows 7 terminal server, so everyone is having the same issue because it is the same computer. 
    Thursday, September 25, 2014 8:30 PM