locked
How To add the EndPoint Behaviour in WebHttp Adapter Properties RRS feed

  • Question

  • Hello All

    I am trying to migrate an application from our DEV to Test environment. I can see the below property in the the DEV

    When I imported the bindings and wanted to change the configuration in the test it is showing me the below error

    And it doesn't show me anything in the behavior.How can I add the endpoint behaviour. Please help me out with this. Thanks

    Tuesday, September 29, 2015 12:18 PM

Answers

  • Hi

    After the assembly is placed int eh GAC, in Windows server 2012, update the machine config file to pick up the dll by adding 

    <system.serviceModel><extensions> <behaviorExtensions>
    <add name="${NameOfTheClassWhichDoesTheImpelentationOfBehaviourElement}" type="${FullyQualifiedName}"/>
    

    Update Machine config at both 32 and 64 bit.

    browse to %windir%\Microsoft.NET\Framework\v4.0\Config and %windir%\Microsoft.NET\Framework64\v4.0\Config\machine.config

    Regards

    K


    • Edited by Koushik984 Tuesday, September 29, 2015 1:35 PM
    • Marked as answer by vdha Tuesday, September 29, 2015 2:10 PM
    Tuesday, September 29, 2015 1:27 PM
  • You need to manually add the extension dll in the Resources and then taking the export of the MSI. This way you will be able to see the external dll's if you are manually exporting the application from BizTalk Admin Console.

    For manually adding the resource in Admin Console:

    • Right Click BizTalk Application in which you want the resource to be added
    • Go to Add -> Resources
    • Click on Add -> Browse the path where your extension dll is placed
    • and then click OK
    • You will be able to see the resource added to the Admin Console now

    Other option is to export the MSI as is and then manually dropping the extension dll in the GAC.

    Rahul

    • Marked as answer by vdha Tuesday, September 29, 2015 2:10 PM
    Tuesday, September 29, 2015 1:47 PM

All replies

  • While deploying on the DEV environment, the external extension assembly must have got registered in the GAC only. And when you are exporting the MSI. it will not pick up the GACed assembly.

    Add the resource in the BizTalk Admin Console or take the assembly and GAC it manually in the test Environment.

    Rahul

    Tuesday, September 29, 2015 12:59 PM
  • I am not sure how can I do that. I dont see any additional resources in the application I am migrating. Its just the application I am seeing

    This is how I exported.

    • Edited by vdha Tuesday, September 29, 2015 1:11 PM
    • Proposed as answer by RahulS_88 Tuesday, September 29, 2015 1:41 PM
    • Unproposed as answer by RahulS_88 Tuesday, September 29, 2015 1:49 PM
    Tuesday, September 29, 2015 1:08 PM
  • Hi

    After the assembly is placed int eh GAC, in Windows server 2012, update the machine config file to pick up the dll by adding 

    <system.serviceModel><extensions> <behaviorExtensions>
    <add name="${NameOfTheClassWhichDoesTheImpelentationOfBehaviourElement}" type="${FullyQualifiedName}"/>
    

    Update Machine config at both 32 and 64 bit.

    browse to %windir%\Microsoft.NET\Framework\v4.0\Config and %windir%\Microsoft.NET\Framework64\v4.0\Config\machine.config

    Regards

    K


    • Edited by Koushik984 Tuesday, September 29, 2015 1:35 PM
    • Marked as answer by vdha Tuesday, September 29, 2015 2:10 PM
    Tuesday, September 29, 2015 1:27 PM
  • Thanks Koushik I added in those two places the C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config and C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config

    <add name="AddHttpHeaderContextBehavior" type="LIC.BT.Common.Behaviors.AddHttpHeaderContext.AddHttpHeaderContextBehaviorExtensionElement, LIC.BT.Common.Behaviors.AddHttpHeaderContext, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f122d7b786bb0156"/>

    Restarted the Host instance and tried again to edit the configuration. Still I am getting the same error. Is there anywhere else I need to make some configuration changes

    Tuesday, September 29, 2015 1:39 PM
  • You need to manually add the extension dll in the Resources and then taking the export of the MSI. This way you will be able to see the external dll's if you are manually exporting the application from BizTalk Admin Console.

    For manually adding the resource in Admin Console:

    • Right Click BizTalk Application in which you want the resource to be added
    • Go to Add -> Resources
    • Click on Add -> Browse the path where your extension dll is placed
    • and then click OK
    • You will be able to see the resource added to the Admin Console now

    Other option is to export the MSI as is and then manually dropping the extension dll in the GAC.

    Rahul

    • Marked as answer by vdha Tuesday, September 29, 2015 2:10 PM
    Tuesday, September 29, 2015 1:47 PM
  • Did you also close and reopen Biztalk Admin console? Because the machine.config file is read and DLLs are picked up during start up of console. 

    Give it a try.

    K

    Tuesday, September 29, 2015 2:03 PM
  • Great Guys. It worked. Thanks
    Tuesday, September 29, 2015 2:10 PM