none
MS Access OnTimer events and Win 10 Build 1903 RRS feed

  • Question

  • I support a number of Access DBs which have processing interfaces. Their job is fairly custom, and quite complex (and the VBA code would take some time to rewrite in another language).

    The processing I/Fs sit on a machine, typically accessed via RDP to kick off the interface. The RDP session is then closed, and the code continues to run periodically using a form's OnTimer event (say every 5 or 10 minutes).

    I've noticed that since Win 10 build 1903, the OnTimer event no longer fires at all after the RDP connection is closed. This is a repeated observation over several separate builds, and the issue can be replicated very easily by creating a blank database with one form writing a log to a table using the OnTimer event, I've made my own simple DB which can be used to check. I can't post a link yet, just remove the space: https:// drive.google.com/open?id=1DRAxCulWPuvpEzeA_A4j_7Ki3m9_MDmN

    Does anyone else have this issue?

    Wednesday, August 28, 2019 10:22 AM

All replies

  • Hi,

    Based on your description, to help you better resolve the problem, I will move the thread to Access for Developers Forum. You may get more helpful replies there. Thanks for your kind understanding.

    Hope you could resolve it smoothly.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Thursday, August 29, 2019 5:59 AM
  • I cannot confirm that behavior. Your app keeps on ticking.

    And from a theoretical point of view that is exactly what should happen. The app does not know if RDP is connected or not. Windows knows, and that's where your issue may be.

    I am on Office 16.0.12022.20000 32-bit, and Windows 1903 (18382.295) (running winver.exe)


    -Tom. Microsoft Access MVP

    Thursday, August 29, 2019 9:01 AM
  • Tom, that's very interesting. I would certainly expect it to continue ticking. However on at least 3 implementations which have had their OS updated to 1903, the process fails (immediately after the OS is updated).

    We have not had any joy with 1903 at all, OnTimer always fails when RDP is disconnected (not logged off, just disconnected by clicking the cross on the RDP toolbar).

    We have tested this DB on many machines with 1903, and all fail to keep ticking when RDP is disconnected. I have no doubt this is a Windows issue. We have raised it with Microsoft, so I wonder if it's been fixed..? Or whether there may be something odd with our implementations in general (this I doubt, as I've tried to keep the tests vanilla).

    Thanks for reading and responding. I'll check versions and get back.

    EDIT: - ok, I just tried this on a machine not involved in any of our client's networks and I don't have the problem (1903 18362.239). This is weird. Anything before 1903 is ok, and anything after this has a problem. At least I have something to go on now, thank you.


    Thursday, August 29, 2019 3:38 PM
  • Have a look at your group policy settings for anything that is set and check to see if it interferes.

    Just takes a click to give thanks for a helpful post or answer.
    Please vote “Helpful” or Mark as “Answer” as appropriate.
    Chris Ward
    Microsoft Community Contributor 2012

    Friday, August 30, 2019 1:50 AM
  • If you are uncertain about a situation maybe you should take a step further and log the whole status...

    Start by opening the application and let it run for an amount of time.

    Does the Timer events works...just log everything  in a text file..e.g put the following in the Timer event

    Dim strLogFile as String
    logFile  = "C:\Logs\Log.txt"
    If len(Dir(logFile)) > 0 then
    Open logFile   For Append As #1    ' Append to the Log file
    Else
    Open logFile   For Output As #1    ' Create the Log File
    End If
    Print #1, Now() & " -- " & "Timer Event Fired"
    Close #1
    Now when ever your Timer event fires you should have an entry in the Log.txt....if something is going wrong you should be able to pinpoint the exact time that failed...maybe the Timer Event works but the subsequent methods fail for some reason... (permission ?) ...of course using the same technique you can also log the Methods that are involved.



    Friday, August 30, 2019 8:37 AM
  • Ok, I may be getting ahead of myself here as the machine I tried it on now fails. There's a chance I didn't follow my steps properly.

    To replicate on a 1903 machine:

    1) Launch the test DB locally, or via RDP (this writes to a log every 20 seconds, this happens to be table based rather than text file based, but that shouldn't make a difference)

    2) Close the session, or lock the machine.

    3) Access the machine again via RDP, then close the session

    4) Wait 5 mins, reconnect to the session via RDP. There is a 5 minute gap in the log.

    https ://drive.google.com/open?id=1DRAxCulWPuvpEzeA_A4j_7Ki3m9_MDmN

    (Test RDP accdb)



    Friday, August 30, 2019 10:05 AM
  • Something in the link is wrong...can you check it.
    Friday, August 30, 2019 10:51 AM
  • Something else...any chance in your RDP issuing a command when you logoff ?
    Friday, August 30, 2019 10:52 AM
  • I can't post links, there's a space after https

    Just to be clear, I'm not logging off at all just d/cing the RDP session (using the cross). No additional commands are running.

    I'm trying this from/to a variety of machines.

    At the moment, for no apparent reason I'm getting roughly a 50% success rate on the same machines. Anything before 1903 is absolutely fine.

    Friday, August 30, 2019 11:43 AM
  • Hi John. I have the same problem and have used timed text logging to show it fails only whilst I am not remotes in. All worked fine for a year until the latest windows updates. Did you ever find a resolution?
    Tuesday, November 12, 2019 12:06 PM
  • I am using Windows 10 Home Version 1903. I downloaded your test db and it worked perfectly. Every 20 seconds it added a new log entry.
    Tuesday, November 12, 2019 4:04 PM
  • Did anyone ever find an answer to this question?  I've searched endlessly and this is the only thing I can find that describes my issue perfectly.  I'm on windows build 1909.  Not sure what I was on before this 100% but I think it was 1809 (corporate build so it gets updated slowly usually).  

    We have an access DB that triggers events on a set timer and as suggested I setup another DB with a timer that just logs to a file.  As soon as RDP disconnects, the timer event stops firing.  If I setup a similar DB and run on a loop doing time checks, it works fine but of course this isn't really ideal.

    Thursday, July 2, 2020 12:51 PM