Windows SDK 7.1 install error- SDKsetup.cab not found RRS feed

  • Question

  • Dear All,

    I am trying to install MS Windows SDK 7.1 and Microsoft Visual C++ 2010 Express on my Windows 7 64 bit 2012 laptop, in order to acquire a compiler compatible with Matlab 2012a. Newer SDK/Visual C versions are not supported.

    This has been a very frustrating process...Visual C download/setup went well, as expected. As to SDK 7.1, I first tried the Web setup, followed instructions, did not have any partial/aborted downloads, started from scratch (cleared any preexisting NET and compiler files). Whatever I do, I get the same and only error message "SDKSetup encountered an error: Unable to find  the file SDKSetup.cab at the installation source. The most likely reason that you received ...". This has been a known issues, judging based on the threads I read...I cleared the cache, and temp folder, retried the web setup, cleared the sdk files again, went on with the ISO istallation (the correct version for X64.. GRMSDKX_EN_DVD.iso). After the latter, I get the confirm message that installation was completed successfully, however the compiler is not installed based on the error messages I get in matlab, as with mex -setup. I find the folders/files in the appropriate path, suggesting that what ISO did was to download but not install the package... when trying to rerun the setup.exe from the destination folder, I get the same SDKsetup.cab error message.

    Very frustrating indeed.. read most if not all the answered threads, I could not find the answer. I thought it might be a certificate update issue, however I am to date with all the Windows updates... and checked manually those pertaining to certificate updates. Checked the root certificates, all are up to date, except two that are expired..mmc > Add/Remove Snap-in > Certificates > Trusted Root Certification Authorities  > Certificates:

    Microsoft Timestamping Root 1997-1999

    Microsoft Authenticode(tm) Root 1995-1999.

    I do not know how to extend them as Windows 7 does that automatically, or it is supposed to...

    However, I do not know if this is the problem, as there are other valid root certif for timestamping and code signing included. I do not want to lead you astray.

    Please help, this is exhausting,


    Tuesday, October 9, 2012 4:16 AM

All replies

  •  There is an issue that the VS2010 SP1 removes the compiler shipped with Windows SDK. You can download the compiler update from http://support.microsoft.com/kb/2519277.

    Visual C++ MVP

    Tuesday, October 9, 2012 3:10 PM
  • Found out that download.microsoft.com was not resolving because backup DNS server did not have forwarders setup correctly.  Fixed and verified with nslookup and web install worked after that.

    Wednesday, January 16, 2013 9:23 PM
  • I have same problem as above mentioned. I download th VS2010 SP1 compiler need to install but it needs installation requirement which is SDK7.1, two problem becomes contradiction......Any solution can suggest?

    Tuesday, March 3, 2020 2:38 AM
  • The SDK patch is for people who experience a component ownership conflict between VS2010 and Windows SDK. If you don't have both installed, the patch does not apply to you. 

    you can get the compiler from either VS2010 or Windows SDK. If you wanna use both install in this order:

    Visual Studio 2010

    Windows SDK 7.1

    Visual Studio 2010 SP1

    Visual C++ 2010 SP1 Compiler Update for the Windows SDK 7.1

    If you have one or more products installed in the wrong order e.g. SDK 7.1 installed before VS2010 then uninstall and start over. 

    Visual C++ MVP

    Tuesday, March 3, 2020 4:52 PM