locked
The request failed with HTTP status 401: Unauthorized + Reporting Service RRS feed

  • Question

  • The request failed with HTTP status 401: Unauthorized while access the Reporting Service methods.
    Tuesday, June 12, 2012 3:47 AM

Answers

  • Hello Devendra,

    I am checking if you still have the same issue. If you still encounter the issue, maybe the following information is helpful to you.

    From your description, the issue is intermittent so that it is not possible to solve via setting the web.config simply, I think. From my opinion, the possible cause is relative to the Kerberos authentication. The authentication service sometimes fails to pass the authentication. If the account belongs to many groups, it is possible that the the authentication verification request exceeds the limitation of the request length. For this scenario, you can apply the change in the following KB article to solve this problem.

    New resolution for problems with Kerberos authentication when users belong to many groups - http://support.microsoft.com/kb/327825

    In addition, the another possible cause is that the Kerberos authentication is not configured properly. For example, the SPN on the server is not set properly. Microsoft provide a great document about the configure Kerberos for reporting service. I consider that you can share it with your reporting service administrator to check whether we can find out the solution from that. Here is the link.

    http://download.microsoft.com/download/B/E/1/BE1AABB3-6ED8-4C3C-AF91-448AB733B1AF/SSRSKerberos.docx

    If you have any questions about this issue, please let me know.

    Regards,

    Edward


    Edward Zhu

    TechNet Community Support

    • Proposed as answer by Edward Zhu Wednesday, June 20, 2012 10:12 AM
    • Marked as answer by Edward Zhu Tuesday, June 26, 2012 12:47 PM
    Tuesday, June 19, 2012 2:46 AM

All replies

  • Check the report log to see which credentials you are passing when the error occurrs.

    Tuesday, June 12, 2012 6:14 AM
  • Hi Irusul,

    actually i dont have the permission on Report Server and Web Server.

    if i publish the code on the web server then this problem becomes intermitant,

    and if debug the code from own machine then this problem gets permanent.

    i am using Service Account for the Report Server which have Browser type permission on the server.

    So, please tell me the what could be reason for this type behaviour.

    Tuesday, June 12, 2012 7:42 AM
  •  

    Hi There

    Please provide more details. I think you are using ASP.net application with report viewer control? Am I right?

    I think it might be issue with Kerberos authentication as you might be doing double hop.

    Please provide some more details

    I will appreciate that

    Many thanks

    Syed Qazafi Anjum


    for more info http://blogs.technet.com/b/rob/archive/2011/11/23/enabling-kerberos-authentication-for-reporting-services.aspx

    Tuesday, June 12, 2012 7:56 AM
  • Hi Syed,

    Yes you are right i am using Asp.net application version 4.0 with Report Viewer version 8.0.0.0 .

    we have 3 servers.

    1 for Report Server

    2 for Web Server and

    3 for Database

    when i debug my code from my machine its give error:401 unathorized in the below method of Reporting Service :-

    CatalogItem[] _returnedItems = this.m_objRS.FindItems(path,

    BooleanOperatorEnum.Or, conditions);

     i am using m_objRS.usedefaultcredentianls=true of repoting service and set Service Account detail in the Application Pool by which we have to access Report Server.

    so, please help me what could be the reason for this problem, if you have any Report Server related solution then please give implementation of the solution also , because as you know i dont have access on Report Server so, i have to inform to my Report Server team for those changes.

    Tuesday, June 12, 2012 10:30 AM
  • There may be two options to fix, one is to use impersonation in .net to make the ASP.Net appear as if it is an authorized user. Or make the server a member of the authorized users active directory group for the SSRS server.

    In web.config add:

    <identity impersonate="true"  />
    <authentication mode="Windows" />




    • Edited by irusul Tuesday, June 12, 2012 11:43 AM
    Tuesday, June 12, 2012 11:33 AM
  • I already try this but, same error is coming.

    i am also try Impersonation by code but does not any impact.

    Wednesday, June 13, 2012 4:19 AM
  • Hello Devendra,

    I am checking if you still have the same issue. If you still encounter the issue, maybe the following information is helpful to you.

    From your description, the issue is intermittent so that it is not possible to solve via setting the web.config simply, I think. From my opinion, the possible cause is relative to the Kerberos authentication. The authentication service sometimes fails to pass the authentication. If the account belongs to many groups, it is possible that the the authentication verification request exceeds the limitation of the request length. For this scenario, you can apply the change in the following KB article to solve this problem.

    New resolution for problems with Kerberos authentication when users belong to many groups - http://support.microsoft.com/kb/327825

    In addition, the another possible cause is that the Kerberos authentication is not configured properly. For example, the SPN on the server is not set properly. Microsoft provide a great document about the configure Kerberos for reporting service. I consider that you can share it with your reporting service administrator to check whether we can find out the solution from that. Here is the link.

    http://download.microsoft.com/download/B/E/1/BE1AABB3-6ED8-4C3C-AF91-448AB733B1AF/SSRSKerberos.docx

    If you have any questions about this issue, please let me know.

    Regards,

    Edward


    Edward Zhu

    TechNet Community Support

    • Proposed as answer by Edward Zhu Wednesday, June 20, 2012 10:12 AM
    • Marked as answer by Edward Zhu Tuesday, June 26, 2012 12:47 PM
    Tuesday, June 19, 2012 2:46 AM
  • Hi Edward,

    Thanks for your Posting.

    these links are very helpfull to me, let me check by implementing Kerbros authontication.

    Tuesday, June 19, 2012 4:43 AM