locked
Problems when moving the SP (v3) database to D: RRS feed

  • Question

  • Hi

    My databases created by default in the windows folder had expanded to the point where i've had to move the standard page file to another drive.  I wanted to get the databases onto the D: drive.  I couldn't find the article about getting SQL Express management studio to connect to the Embedded sql (Windwos Internal Database).  So i got SQL Manager Lite by EMS and that connected by instance name.  So i detached my 4 databases and copied them to the D: and reattached them.  Now i get the following error in the application log and i cannot get the sharepoint site to come up.

    The description for Event ID ( 27745 ) in Source ( Windows SharePoint Services 3 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: #50071: Unable to connect to the database WSS_Content on SERVERNAME\Microsoft##SSEE.  Check the database connection information and make sure that the database server is running..

    I get the following error in a browser window when i try to browse onto the site:

    HTTP/1.1 404 
    Connection: close
    Date: Fri, 06 Nov 2009 13:20:46 GMT
    Server: Microsoft-IIS/6.0
    MicrosoftSharePointTeamServices: 12.0.0.6219
    X-Powered-By: ASP.NET
    The 4 databases i had moved are:

    SharePoint_AdminContent_42d83c37-9e43-4c6d-a613-762a48731bff.mdf & .ldf
    SharePoint_Config_2e3d7f09-203c-491c-b305-1921ef0eb2f7.mdf & .ldf
    WSS_Search_BULGARIA.mdf & .ldf
    WSS_Content.mdf & .ldf

    All services have started ok and i have a feeling i need to be doing something along the lines of stsadm -o deletecontentdb and then reassociating the site with the contentdb but i cannot seem to get the commands to work. I get missing operation name or the operation name is invalid. 

    Can anyone help me please.  I've looked at this so long i can no longer think straight.

    Thanks

    Greg
    • Edited by Mike Walsh FIN Friday, November 6, 2009 2:53 PM Title of "Sharepoint 3" shows the tiredness referred to in the text. Replaced by something that indicates the problem area.
    Friday, November 6, 2009 1:32 PM

Answers

All replies

  • Hi,

        I was just seeing the same error on one of my sites. which is missing......

          The site may have got deleted/moved/ renamed.

         Try opening the site after adding /default.aspx to the site URL

           you will get 404, File not found error..........

         http://support.microsoft.com/default.aspx/kb/248033


    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    Friday, November 6, 2009 1:37 PM
  • Hi Aj

    Thanks for the quick reply.  I'm really sure this isn't an IIS config issue as i have not changed or moved / removed the webfolders or their associated configurations and this was 100% working right before i detached the databases.  I'm pretty sure this is the sharepoint application being unable to locate/read the content database and as such is unable to start.  The biggest problem is that because the application will not start i'm unable to get into the Sharepoint Administration section to change anything to do with the databases so i'm unsure quite how i'm going to assign this web app to use a new databse (well the same database but i guess it's taken a new name or GUID since being detached/attached).  Is there any way i can get a list of the sites and their database configs out of the sharpoint app using stsadm.exe or something like it?  Then i can either assign the database the same name or change the current config to use the new DB ID? 

    Does that make any sense?

    Thanks

    Greg
    Friday, November 6, 2009 2:30 PM
  • You can try with the enumsites command to list all the sites inder a webapplication.

    http://technet.microsoft.com/en-us/library/cc262492.aspx

    You can find the details regarding the content database the webapplication is associated with from the central admin at manage content database  at central admin- Appln management - content mngmnt.

    Also you can attach or detach content data base

    attach:

    http://technet.microsoft.com/en-us/library/cc263422.aspx

    detach:

    http://technet.microsoft.com/en-us/library/cc262449.aspx

    Is this what u  r looking for,,,,,,,




    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    • Edited by Ajith George Friday, November 6, 2009 2:49 PM more data
    Friday, November 6, 2009 2:47 PM
  • Hi Aj

    I ran the enum for my site  and go the following output:

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsadm -o enumsites -url http://bulgaria
    <Sites Count="3">
      <Site Error="Unable to connect to database.  Check database connection informa
    tion and make sure the database server is running." />
      <Site Error="Unable to connect to database.  Check database connection informa
    tion and make sure the database server is running." />
      <Site Error="Unable to connect to database.  Check database connection informa
    tion and make sure the database server is running." />
    </Sites>
    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>

    The Windows Internal Database (MICROSOFT##SSEE) is running and i can connect to it with SQL express Management Studio 2005 and browse the database tables etc, but of course these are the databases that have been detached, copied to the D: and reattached.  Then when i couldn't access my sharepoint site after that i detached the D: versions and reattached the original files in the C:\Winnt\Sysmsi folder but that didn't seem to help. 

    It would appear that all 3 sites point to the same content DB but am i able to delete the db references within the site without being able to find out what the 3 site names are to specify them?  Or is there a way to find the database name exactly as it is being referenced by the application so i can double check the names?  In Event viewer the errors in the application log refer to the database as WSS_Content which is the name that the database currently has.  Is there any other unique ID or something like that which would have changed by being detached and reattached?

    Thanks

    Greg
    Friday, November 6, 2009 3:41 PM
  • Oh sorry forgot to mention i can't access any web management for the Sharepoint site because the Application isn't running because it can't access the database. 
    Friday, November 6, 2009 3:44 PM
  • Hi Greg,

      Last time when i saw such an error "Unable to connect to database....." was when the database sever which hold my content database went in suspended mode.

     Not confirming that yours is the same case, Try accessing the database server and see what mode is it currently.

    Also please see the below link,

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/a44796d4-7a14-42de-937d-80a3822b2aba/


    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    Friday, November 6, 2009 3:46 PM