locked
Cannot search in Windows Phone Store by protocol RRS feed

  • Question

  • Hello,

    I have app A and app B, both are WP8.0 app and published in the store. App A has a button to open app B. I have defined a protocol in B's AppManifest, and use Launcher.LaunchUriAsync (https://msdn.microsoft.com/en-us/library/windows/apps/xaml/hh701480.aspx) in app A to open app B.

    It's worked find if both app are installed. But if app B not installed, it will search in the wp store to find app B. The problem is app B can't be found. It was worked before the Windows Dev Center upgrade to support Windows 10. I can't use the Launcher.LaunchUriAsync with LauncherOptions since i have to support WP 8.0.

    Regards,

    Liem


    • Edited by Liem Vo Wednesday, September 16, 2015 11:17 AM
    Tuesday, August 18, 2015 4:56 AM

All replies

  • Hi Liem,

    Are you saying its not working on Windows Phone 8.0, or Windows Phone 8.1. I don't have an 8.0 device handy, but I tested launching a custom protocol from a Silverlight app on Windows Phone 8.1 and it correctly displayed apps that can handle that protocol.


    Mitch Denny

    Tuesday, August 18, 2015 6:20 AM
  • Hi Mitch,

    Thanks for your reply. It's not worked on any devices (8.0, 8.1, 10 DP). In this case, App B hasn't been installed yet:

    https://dl.dropboxusercontent.com/u/17484775/1.png

    https://dl.dropboxusercontent.com/u/17484775/2.png


    It was worked before, WP store can find app B. But after i have uploaded new version of app B recently, it stop working.

    Regards,

    Liem


    Tuesday, August 18, 2015 7:38 AM