locked
Error: Updating Site Content Type Failed - InfoPath 07/SharePoint 07 RRS feed

  • Question

  • I have been working with InfoPath07 and SharePoint Moss 07 for two years.  I have recieved the Updating Content Type error in the past which I got around by creating new library's. This was over a year ago and happened only a couple times.

    Recently, my dept did a database migration.  About 3 weeks prior to the migration I started having troubles with publishing InfoPath.

    First issue, it would take about three hours for my form to go through to the form/document library.  Sometimes they would publish, other times I would get Updating Content Type Failed.

    Now that our databases have been migrated, I don't have to wait three hours to get my error.  I get my error on (1)existing forms that just needed interface updated (no changes to forms content), (2) existing forms that have no content at all, (3) and brand new forms that have never existed, with no content.

    I have tried:

    • Deleting some content (fields)
    • Deleting all content
    • Deleting the entire library and starting fresh (including any content types in Central Admin or workflows associated)
    • Creating a brand new form with no content type

    I have been researching and trying to figure this issue out for at least three months. I am still getting this error with every form I publish to update the forms library; however, I do not have any issues publishing to Administrator.

    NEW ISSUE: Yesterday I was able to publish my forms.  Didn't go through very fast, but it didn't take 3 hrs either.  The issue lied with my SharePoint Administrator getting permission errors when trying to approve any form. He logged in as both Administrators and got the same error. Yesterday, late afternoon, I was back to my original issue with not being able to publish any form.

    Please help.


    Keek
    Thursday, April 7, 2011 9:20 PM

All replies

  • Have you reviewed the sharepoint log to see if there is a more detailed error there? 

    Your logs by default are in the 12 hive on the sharepoint server:  c:\program files\common files\microsoft shared\web server extensions\12\logs

    Friday, April 8, 2011 1:17 PM
  • Yes, we have checked the logs on the server and the logs on my machine.

    Also, we have tried publishing on other machines under different accounts and we are still unable to publish, getting the same error.


    Keek
    Friday, April 8, 2011 1:49 PM
  • Did the logs give any additional information - if so, could you please post those messages here?
    Friday, April 8, 2011 1:52 PM
  • No messages from the logs
    Keek
    Friday, April 8, 2011 2:00 PM