none
How to specify url with space into WsHttp URI ? RRS feed

  • Question

  • We have service with space in url, and when we are trying to use it with %20 like :

    http://myserver/my%20folder/myservice.svc
    

    Biztalk is giving an error and suspending message. However URL is resolvable into internet explorer.

    What is correct way to specify URIs with space in BizTalk ?

    Friday, October 16, 2015 4:54 AM

Answers

  • Error while specifying a connection URI for a WCF-Custom port in BizTalk Server

    Problem

    BizTalk Server gives the following error when you specify a connection URI to connect to the SAP system.

    Error saving properties.
    (System.ArgumentException) The specified address is invalid.
    (System.ArgumentException) Invalid address;
    "<connection URI>" is not a well-formed absolute uri.
    

    Cause

    The connection URI does not adhere to the standard encoding format. For example, the value for a parameter might contain a space.

    Resolution

    Make sure the connection URI you specify adheres to the standard encoding format. For example, a blank space must be replaced by "%20".

    Source: Troubleshooting Operational Issues


    Sandro Pereira
    DevScope | MVP & MCTS BizTalk Server 2010
    http://sandroaspbiztalkblog.wordpress.com/ | @sandro_asp
    Oporto BizTalk Innovation Day | 14th March 2013 – Oporto, Portugal
    Please mark as answered if this answers your question.

    Thursday, October 22, 2015 9:48 PM
    Moderator

All replies

  • Hi ,

    The correct format is like below

     http://host[:port]/apppath/wcfservicename.svc

    Were host[:port] is The name of the computer where you have deployed your WCF service. A colon and the port number can follow this server name

    apppath is The name of your virtual directory and the Web application path.

    wcfservicename.svc is The name of the WCF service .svc file.

    Thanks

    Abhishek

    Friday, October 16, 2015 5:12 AM
  • Just leave the space as is in the configuration. If you use dynamic ports and then wish it set then use the urlencode functionality (that is what also converts " " to %20).

    Regards.

    Friday, October 16, 2015 5:13 AM
  • Hi,

    Where is your service 'myservice.svc' located, Seems it could be 

    http://myserver/my 20folder/

    Then please try below (As Shankycheil mentioned) leave it with space,

    http://myserver/my 20folder/myservice.svc


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Friday, October 16, 2015 5:59 AM
    Moderator
  • Problme is when I leave space into URI I've got error box 

    Error saving properties. (System.ArgumentException) The specified address is invalid. (System.ArgumentException) Invalid address; "<connection URI>" is not a well-formed absolute uri.

    I've found this page : https://msdn.microsoft.com/en-us/library/cc185364%28v=bts.10%29.aspx?f=255&MSPPError=-2147217396

    and It's saying

    Resolution

    Make sure the connection URI you specify adheres to the standard encoding format. For example, a blank space must be replaced by "%20".

    Friday, October 16, 2015 3:54 PM
  • Not sure.. But u try using %20 or a +. see if any of these two works for u..

    Regards &lt;br/&gt; When you see answers and helpful posts,&lt;br/&gt; please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    Friday, October 16, 2015 4:59 PM
    Answerer
  • Problme is when I leave space into URI I've got error box 

    Error saving properties. (System.ArgumentException) The specified address is invalid. (System.ArgumentException) Invalid address; "<connection URI>" is not a well-formed absolute uri.

    I've found this page : https://msdn.microsoft.com/en-us/library/cc185364%28v=bts.10%29.aspx?f=255&MSPPError=-2147217396

    and It's saying

    Resolution

    Make sure the connection URI you specify adheres to the standard encoding format. For example, a blank space must be replaced by "%20".

    Hi,

    You should try what Pi_xel_xar mentioned above, but my concern, why your are using space, why not trying '_' or without space.

    A URL must not contain a literal space. It must either be encoded using the percent-encoding or a different encoding that uses URL-safe characters (like application/x-www-form-urlencoded that uses + instead of %20 for spaces).

    But whether the statement is right or wrong depends on the interpretation: Syntactically, a URI must not contain a literal space and it must be encoded; semantically, a %20 is not a space (obviously) but it represents a space.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Proposed as answer by Angie Xu Thursday, October 22, 2015 7:15 AM
    Saturday, October 17, 2015 2:59 AM
    Moderator
  • Is very common for example in SharePoint libraries that the URL contain spaces as any other HTTP address.
    While configuring in BizTalk I think you can specify either a space, by pressing the space bar key or by providing %20.
    Whenever you export your BizTalk binding files, you will always find that spaces are represented as %20

    Sandro Pereira
    DevScope | MVP & MCTS BizTalk Server 2010
    http://sandroaspbiztalkblog.wordpress.com/ | @sandro_asp
    Oporto BizTalk Innovation Day | 14th March 2013 – Oporto, Portugal
    Please mark as answered if this answers your question.

    Thursday, October 22, 2015 9:46 PM
    Moderator
  • Error while specifying a connection URI for a WCF-Custom port in BizTalk Server

    Problem

    BizTalk Server gives the following error when you specify a connection URI to connect to the SAP system.

    Error saving properties.
    (System.ArgumentException) The specified address is invalid.
    (System.ArgumentException) Invalid address;
    "<connection URI>" is not a well-formed absolute uri.
    

    Cause

    The connection URI does not adhere to the standard encoding format. For example, the value for a parameter might contain a space.

    Resolution

    Make sure the connection URI you specify adheres to the standard encoding format. For example, a blank space must be replaced by "%20".

    Source: Troubleshooting Operational Issues


    Sandro Pereira
    DevScope | MVP & MCTS BizTalk Server 2010
    http://sandroaspbiztalkblog.wordpress.com/ | @sandro_asp
    Oporto BizTalk Innovation Day | 14th March 2013 – Oporto, Portugal
    Please mark as answered if this answers your question.

    Thursday, October 22, 2015 9:48 PM
    Moderator