none
I5 7200U and HD620 laptop issue

    Question

  • While testing the new i5 7200u and HD620 graphics laptop I have run into a problem with the body tracking and face tracking.

    - Windows 10 Anniversary

    - Newest Kinect driver loaded

    - Kinect verify says that it is all working at 30 fps.

    - Infrared seems to be working.

    - Depth seems to be working.

    - HD camera is working.

    - ALL Body tracking and Face tracking is not working. :(

    Has anyone tried the new Intel chipset?

    Reagrds, David

    Tuesday, November 08, 2016 4:16 PM

Answers

  • Hi David,

    Your symptoms don't entirely support the suggestion I have below, but it is worth a try.  There are some power management changes that occurred in the latest Intel chipsets.  This has caused some problems with Kinect but more around it disconnecting from the system or not maintaining 30FPS. 

    Please add try the following:

    From an elevated command prompt, execute:

    reg add HKLM\System\CurrentControlSet\Control\Processor /v Capabilities /t REG_DWORD /d 0x7e060

    then reboot the computer.

    If that doesn't solve the problem, then just delete the regkey

    Monday, January 09, 2017 11:22 PM
    Owner

All replies

  • Are you sure you are using the new API correctly? Accessing skeleton data through 1DBuffers(That's what MS said is to be used for such things)? Check this sample for skeleton tracking. Joints are now renamed to TrackedPoses. So be warned that it's gonna be confusing.

    As far as face module goes, I'm thinking this is either under the MediaCapture API or through 1DBuffers. Not sure.

    Wednesday, November 09, 2016 10:45 AM
  • Good morning, this is not a UWP.  It works on Gen 6 systems fine.

    I bought a another system last night with same specs from different vendor and I got the same results.

    David

    Wednesday, November 09, 2016 4:21 PM
  • Hi, I have reported this to Microsoft.  I hope they look into it.

    Regards, David

    Wednesday, November 09, 2016 5:03 PM
  • The Kinect Studio app will not connect with the Intel Gen 7 computers I tested. It works on Gen 6 and others.

    David

    Wednesday, November 09, 2016 5:30 PM
  • But isn't the newest win10 anniversary driver supposed to only work with UWP? It's a Win10 SDK and Win10 only support UWP. At least that's what I've understood so far.

    Try changing the driver to use the old one instead and the regular SDK. And try to use KinectStudio etc.


    Wednesday, November 09, 2016 6:14 PM
  • This is a bug and not a Windows Anniversary edition UAP problem.

    It is a problem with the driver.


    David

    Thursday, November 10, 2016 7:46 PM
  • I see. Well then, good luck to you.
    Thursday, November 10, 2016 8:04 PM
  • Hi David,

    Your symptoms don't entirely support the suggestion I have below, but it is worth a try.  There are some power management changes that occurred in the latest Intel chipsets.  This has caused some problems with Kinect but more around it disconnecting from the system or not maintaining 30FPS. 

    Please add try the following:

    From an elevated command prompt, execute:

    reg add HKLM\System\CurrentControlSet\Control\Processor /v Capabilities /t REG_DWORD /d 0x7e060

    then reboot the computer.

    If that doesn't solve the problem, then just delete the regkey

    Monday, January 09, 2017 11:22 PM
    Owner
  • Thanks for getting back to me.  I have returned the computers but I will try to get a new Gen 7 system to try.  I tried 2 systems (Dell and HP) with the same results.

    The FPS was 30, however I could not get any skelton data.  Everything appeared to be working.  Have you tested any of the new Gen 7 chips?

    Is this going to be able to be addressed?  David

    Tuesday, January 10, 2017 2:46 PM
  • Hi David,

    The symptoms that we were seeing with some Intel Gen 7 chips were not ST not working.  However, I wanted to see if this solution would solve your problem.  The issue is that Intel changed their power management and it would reduce the amount of throughput on the USB 3.0 port.  This would cause Kinect to fail.  The regkey turns off the power management and allows the USB 3.0 port to run at specification for data throughput.  Kinect requires the USB 3.0 port to operate at full USB 3.0 specifications due to the amount of data we transport over Kinect.  If the USB 3.0 port is not operating withing compliance, Kinect will fail.  There isn't anything we can do to resolve a non-compliant USB 3.0 port issue.

    Wednesday, January 11, 2017 6:15 AM
    Owner
  • Kevin, thank you for your help.  This registry change, allowed the camera to work with Kinetisense.  The Skeletal data is now picking up.

    It did not work on another computer until I made this change.

    Can you tell me if this should be done on all Generation 7 Intel chips?

    Regards, David Schnare

     
    • Edited by Kinetisense Monday, January 23, 2017 10:18 PM wrong grammar
    Monday, January 23, 2017 10:08 PM
  • Hi David,

    That is good news!  The only down side to the reg key is that the machine will not go into power savings mode.  So, if you are running on battery, you will most likely see a reduced power on time.  If you are always plugged in, I guess you will be drawing more electricity.  

    This is the only solution we have as we are working around a power management issue with the Intel CPU that is overriding the requirements for USB 3.0 for maximum data transfer rates.  

    Other customers that have had similar problems have only been able to solve the problem by applying the registry key.

    Tuesday, January 24, 2017 6:49 AM
    Owner
  • Thank you for following up with me.  One more question.  Does this impact all the Gen 7 chips? 

    Regards, David

    Wednesday, January 25, 2017 3:08 AM
  • Hi Kevin, we are still running into problems even with the change that you recommended.  It is not working with the following computer.

    Dell Latitude

    http://www.dell.com/us/business/p/inspiron-15-5567-laptop/pd?oc=smi155w10h2310&model_id=inspiron-15-5567-laptop

    We get 30 FPS without any problems with kinect verify.  Skelton Data does not work even with your registry suggestion.  Is there any other solutions or recommendation around this issue.

    Would you know why we get consistent 30 FPS but no skelton data?  Is there any other trouble shooting we can do.  OUr customer bought 6 of these and now we are stuck.

    Regards, David


    Monday, January 30, 2017 9:47 PM
  • Hi what I have found is that the Kinect Driver will not update to the latest driver in the Netherlands.  It stays on the 2014 driver which is problematic.  This has happened on a number of computers in the Netherlands.

    This is a brand new Dell computer which has Windows 10 Anniversary with all updates done.

    I have tried everything, this seems to be in a problem in the Netherlands.  What might be the problem be?

    We need to fix this to see if the reg entry works.


    Tuesday, January 31, 2017 2:51 PM
  • Tuesday, January 31, 2017 2:52 PM
  • Sorry I have no idea how to fix this but since I'm also from the Netherlands I just double checked here.
    It seems the dialog box shows the exact same date and version number as the one you just posted.

    However my sensor does seem to work correctly on my desktop machine with i7-6700 CPU, Asus Z170 Pro Gaming motherboard with onboard USB chipset, NVidia 1080 GPU.



    Brekel

    Tuesday, January 31, 2017 3:45 PM
    Moderator
  • Thanks for confirming this.  I am not sure why the new driver is not deployed to computers in the Netherlands.

    The new driver is important for newer computers especially with the Windows Anniversary Build.  I hope someone from Microsoft can look into this and help.

    I can not continue testing with the Gen 7 chip issue until I get this straightened away.  Regards, David

    Tuesday, January 31, 2017 4:51 PM
  • This afternoon I started with a complete clean Windows 10 Anniversary build.  Clean!

    When we plug the computer in it looks like the driver is loading however when finished there is a problem in device manager.  When you try to manually update the driver it shows the following:

    Tuesday, January 31, 2017 9:57 PM
  • Hi David,

    Can you please contact CSS regarding this particular issue as it appears there is maybe some bug for the region you are located that we are not aware of?

    I have not seen the behavior of ST not working but getting 30 FPS.  I have also not been aware of the issue you are reporting above of the latest drivers not coming down. 

    Tuesday, January 31, 2017 10:57 PM
    Owner
  • Thanks, for the feedback.

    Do you know what CSC I would contact?  Do you folks have a way to open a case to investigate this with the driver delivery group?

    You reg fixed the disconnecting but the Skelton Data is not reading.  I am including a picture.  As you can see it is consistent 30 fps but the small lines on chest should be our skelton lines.  They never lock on.  There is no data being read.

    This is 7200u with the 2014 driver.  I am not sure if the new driver would work.

    Tuesday, January 31, 2017 11:18 PM
  • On a very positive note, i just tested an HP i7 7500U computer.  This system is working perfectly here in Canada.

    Everything works tremendously.  At this point,

    1. I can not load the new driver in the Netherlands.

    2. The 2014 is running at 30 fps but not locking on for skelton data.  I am not sure if the problem is the driver since I can not test it.

    Actions

    1. I am trying to find how to contact the CSC for kinect driver delivery in Netherlands area.

    2. Once I load the driver I can test the camera again.

    David

    Tuesday, January 31, 2017 11:47 PM
  • I was able to build a driver zip file which I transferred to the customer in Netherlands.  I unzipped the folder and was able to manually browse and install the 2016 driver.

    At this point it will cost me 499 to open a CSC incident on this.  I am not prepared to pay 499 to report this issue in the Netherlands.

    David

    Wednesday, February 01, 2017 9:20 PM
  • Hi David -

    There was an issue where the new Kinect driver was not distributing to all locales.  This was just now fixed (within the last 24 hours) and you should now be able to update to the new driver via device manager regardless of locale.

    Please let me know if you're still having problems obtaining the driver and I'll look into it.

    Bryan

    Friday, February 03, 2017 10:53 PM
  • I wasn't the one having the issue, but I just wanted to confirm that I was just able to update the driver manually here in The Netherlands.

    Brekel

    Monday, February 06, 2017 11:24 AM
    Moderator
  • Thanks all for your work on this.

    I appreciate MS working with us.

    David

    Monday, February 06, 2017 3:23 PM
  • Hi,

    I am having the same issue - KinectV2 working smoothly at 30fps but no skeleton tracking in Kinect Studio or Body Basics :( Configuration is  Dell Inspiron 13-7378, Core i7-7500U, Intel HD Graphics 620, Intel USB3 eXtensible Host Controller. All drivers are up to date. Also tried the registry change but no success. What can this be? An OpenCL problem?

    Thanks

    B

    Friday, February 10, 2017 3:36 PM
  • Same here,

    Lenovo YOGA 910, Core i7-7500 Intel Graphics 620, everything up to date, all streams fine at 30 fps but no skeleton tracking.

    Reg suggestion did not solve the problem.

    But something interesting: I installed KinectStudio and copied a recorded file from a different machine on the laptop. Playback showed the skeleton ONLY IF NOT CONNECTED. As soon as I hit the connect button, the skeleton stream was gone. Any ideas? How to fix?

    Thanks

    BK

    Monday, February 13, 2017 7:53 PM
  • Hi, I was hoping Microsoft will provide some help with diagnosing this issue.  It is different from machine to machine.  David
    Monday, February 13, 2017 8:32 PM
  • Hi David,

    We have looked at this more.  There is a bug with the latest Intel GPU's that we have been able to reproduce.  We know it is in the GPU as we have a tool that allows us to turn off the GPU and run everything in the CPU and then those CPU's run without a problem.  By default the Kinect SDK prevents users from enabling the tool to essentially emulate the GPU in the CPU.  We have logged a bug at Intel as the fix requires an update to their driver for those latest CPU's with their integrated GPU.  

    Right now we don't have any workaround to this particular problem for the affected CPU's with the integrated GPU.  The only short term workaround we know of is using a different brand discrete GPU on existing PC's that exhibit this problem or different CPU brand (i.e. AMD/Nvidia).  

    Tuesday, February 14, 2017 6:36 AM
    Owner
  • Thanks so much for keeping us updated.  If you hear when this is fixed please let us all know.  We will continue to sell Gen 6 computers.  Regards, David
    Tuesday, February 14, 2017 1:27 PM
  • Hi David,

    Someone from engineering should be reaching out to you with an Intel alpha version of the driver for you test on the affected machines.  Ping the forum if you don't hear from them in a couple of days and I will chase them down.

    Tuesday, February 14, 2017 4:45 PM
    Owner
  • Hi Kevin,

    I would love to try the alpha version when available, too. 

    We were going to send back the KabyLake+HD620 laptop but if a solution 
    is available soon, that would be much better.

    Thanks!
    Best

    B

    Tuesday, February 14, 2017 5:44 PM
  • Hi David,

    There should be a driver update at the end of February.  We have replicated on machines with your HW with that driver and verified ST working.  

    Wednesday, February 15, 2017 2:25 AM
    Owner
  • Good day, I am just checking how the driver update is coming?  Regards, David
    Monday, February 27, 2017 2:04 AM
  • Hi, Kevin

    we used Kinect camera in Skype for Business as a web camera, but the picture was shown to a mirror picture. Is there any methods to solve this probem, or the latest Kinect driver will solve this issue? Thank you!

    Friday, March 10, 2017 8:16 AM
  • Hi everyone, 

    I'm also using a DELL XPS 13 9360 with a i7-7500 CPU and have exact the same problem. Everything is working (also camera is working well at 30 fps) except for skeleton tracking. I'm doing my final degree project in Biomedical Engineering trying to adapt the kinect to obtain alarms depending on the patiens movement, and I am stucked because I can not get skeleton data. Since I recieved my kinect v2 yesterday, I was not aware of the problem.

    Is the new update going to be released soon? Is there any way I can access this alpha version?

    Best regards, 

    Biel

    Tuesday, March 14, 2017 5:10 PM
  • We are still waiting on Intel to release the updated driver that will resolve this problem.  We thought it was going to be end of Feb, but do not have a current updated release date.
    Tuesday, March 14, 2017 5:14 PM
    Owner
  • If you would like me to have a look remotely to make sure all is set I would.

    I have got the i7 working on the HP.  I know that it is depended on chipset.

    please email me at david@kinetisense.com and I will confirm.

    David

    Tuesday, March 14, 2017 5:21 PM
  • Is this the video driver?  What driver is being updated?


    David

    Tuesday, March 14, 2017 5:22 PM
  • Hi

    I have the same issues with a Assus ROG G750GY laptop i7-4720HQ. Kinect 2 has stopped working after Windows 10 Anniversary update.

    I'm a developer actively developing for Kinect 2, and I wasn't able to start Kinect 2 on my development machine for several months now. I've tried all workarounds possible, to no avail. This situation has become extremely frustrating. 

    Please let us know as soon as you have more info available.

    Catalin

    Friday, March 31, 2017 12:46 PM
  • A couple of things.

    1. What do you mean it stopped working?

    2. Would you be open to me having a look?  Email me if you like at david@kinetisense.com

    David

    Friday, March 31, 2017 1:08 PM
  • Hi,

    To answer your question, skeleton and color streams were not working.

    A potential fix:

    Today I've uninstalled Kinect 2 SDK, rebooted the PC (it seems to be a required step), then reinstaled the SDK and Kinect2 is now working, but the verifier warning has not disappeared. 

    With kind regards,

    Catalin Pop

    Friday, March 31, 2017 1:21 PM
  • Kevin Collins, would you be able to look at the new question I posted?  I need some recommendations.  I have a very important client and I can not get the camera working.

    David

    Monday, April 17, 2017 8:35 PM
  • 안녕하세요

    장치관리자에서 그래픽드라이버를 사용안함으로 설정하게되면
    골격을 잘가져오는걸 확인하였습니다.

    인텔에서 그래픽드라이버를 업그레이드 해주기전까지는 임시로 사용할수 있습니다.

    저의 컴퓨터 사양은 아래와 같습니다.
    - Intel HD Graphics 620
    - Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz (4 CPUs), ~2.7GHz
    - Windows 10 Home 64Bit

    -----------------------------------------

    Hi,

    If you disable the graphics driver in Device Manager
    I have confirmed that I get the skeleton well.

    Until Intel upgrades the graphics driver, it can be used temporarily.

    My computer specifications
    - Intel HD Graphics 620
    - Intel (R) Core (TM) i5-7200U CPU @ 2.50GHz (4 CPUs), ~ 2.7GHz
    - Windows 10 Home 64Bit







    Friday, April 21, 2017 2:03 PM