locked
WLK 1.6 TCG TPM Integration Test RRS feed

  • Question

  • Hi,

    I'm running a TCG TPM Integration Test on Intel platform(DH61CR) with Infineon TPM module.

    And when I run the test, Test failed and stopped on the phase of "TPM PPI Logo Test GetResponse 1".

    I don't know why but with DOS tool, tcgbios.exe, all the tests are PASS (with TPM Enable/Activated) and the test item "TPM Integration Logo test" is passed.

    Now, I'm wondering failed result can be ignored or not, and want to know what kind of default state is required for this test. (when I run tpmppi /t 50, log indicated that some items like disable/deactivated's default state is wrong)

    Here is the error logs..

    Result from tpmppi /n acpisubmitsetreq01

    Result from request: 2

    Error: 0x0, Error 0x00000000

                      General failure returned from BIOS attempting to make ppi request

                      File=(null) Line=0

    Error: 0x0, Error 0x00000000

                      Failed with hr: 80004005

                      File=(null) Line=0

    End: Fail, 21 : ACPISubmitSetReq01, TUID=FAD3BC46-3DF1-4D13-A1D2-91DBD410921E, Repro=tpmppi.exe  /n ACPISubmitSetReq01

     

    Result from tpmppi /t 50

    Verifying that the default perm flags are set

    Disabled: 0

    Error: 0x0, Error 0x00000000

                      Disabled is wrong default state!

                      File=(null) Line=0

    Ownership: 1

    Deactivated: 0

    Error: 0x0, Error 0x00000000

                      Deactivated is wrong default state!

                      File=(null) Line=0

    PubEK Readable: 0

    Error: 0x0, Error 0x00000000

                      readPubek is wrong default state!

                      File=(null) Line=0

    And

    Error: 0x0, Error 0x00000000

                      Failed with hr: 80004005

                      File=(null) Line=0

    End: Fail, 50 : VerifyDefaultBasic, TUID=ED5DB25B-BF8F-4A00-87EC-E9966E1BCFB4, Repro=tpmppi.exe  /t 50

     

    Wednesday, September 28, 2011 11:58 AM

Answers

  • The first failure is probably because you did not implement the TCG Physical Presence Interface Specification.  The test is attempting to submit a request to do a physical presence action on the next boot.  Check the Physical Presence Interface specification 1.1 or 1.2 for the informational  text note about the method to submit an operation to the pre-os environment.

     

    Thursday, January 26, 2012 10:25 PM
  • I found a solution. You must use the same BIOS version as show in the INTEL MLP REPORT of your motherboard model.

    It is OK for me.

    Thursday, March 8, 2012 7:46 PM

All replies

  • The first failure is probably because you did not implement the TCG Physical Presence Interface Specification.  The test is attempting to submit a request to do a physical presence action on the next boot.  Check the Physical Presence Interface specification 1.1 or 1.2 for the informational  text note about the method to submit an operation to the pre-os environment.

     

    Thursday, January 26, 2012 10:25 PM
  • I have the same issue. Do you have any solution? I'm running a TCG TPM Integration Test , and the test fail.

    Thanks in advance

    Thursday, March 8, 2012 2:20 PM
  • I found a solution. You must use the same BIOS version as show in the INTEL MLP REPORT of your motherboard model.

    It is OK for me.

    Thursday, March 8, 2012 7:46 PM