none
Problem with adding second node to SQL 2016 Cluster

    Question

  • Hi,

    when i try to add second node to SQL 2016 Cluster i get following error:

    The cluster group could not be determined for resource 'Cluster IP Address'.  Error: There was a failure to call cluster code from a provider. Exception message: Generic failure . Status code: 4098. Description: Not found

    .

    Error code 0x86D80034.

    :(

    Thursday, March 9, 2017 11:21 AM

All replies

  • Hi Al Hasoob,

     

    Based on the error message, this problem can be caused by that the account you used to add this node has no enough permission, did you use an account which is not a member in the Domain Administrator Group, please check it.

     

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 10, 2017 8:56 AM
  • I had the exact same error adding a new node to an existing SQL2016 cluster even running the install under domain admin credentials.
    Using the GUI it would just hang on "please wait" during the cluster node check.  Same issue never completing running an unattended install with the error just silently in the detail.log.

    Managed to resolve by ensuring the second node had the same Windows patch level (in this case the Windows Server 2016 "2017-05" CU) as the first node in the cluster.

    • Proposed as answer by Robin_RDG Tuesday, February 13, 2018 10:58 AM
    Monday, June 5, 2017 10:16 AM