locked
Any way to hide windows UI while running a full-screen program?

    General discussion

  • Let's say you want all your attention on one single program, witch you are running at full-screen. To move around that program you need to move the cursor over the side of the screen. Well, that is not working, because when you move the cursor over the left side of the screen, some windows related UI appears and doesn't let the cursor be on the program anymore, same when you place the mouse over the bottom-left corner, the "new start menu" appears. So basically you can't pan the screen around with your mouse over the left side or in the bottom-left diagonal.

    Is there any way to override this feature so that the windows UI does not appear unless you close that full-screen program / press the windows key / press alt + tab / etc.?

    Friday, September 16, 2011 8:49 PM

All replies

  • Hey there,

    Can you clarify? Are you referring to when you hover the mouse on the left side/edge of the screen, it pops up the previous application to select?

    I do not see an option to disable this feature in the Windows Developer Preview.

    Regards,

    Bobby

    Sunday, September 18, 2011 9:32 PM
    Answerer
  • Hey there,

    Can you clarify? Are you referring to when you hover the mouse on the left side/edge of the screen, it pops up the previous application to select?

    I do not see an option to disable this feature in the Windows Developer Preview.

    Regards,

    Bobby

    Exactly that. Thanks for the answer! If I find a way to disable it I'll post it.
    Sunday, September 18, 2011 9:47 PM
  • One pixel worth of the left and right sides of the screen is reserved for Windows system UI. You can't override this because if you did users would have no way of switching to another application.
    Sunday, September 18, 2011 10:11 PM
  • One pixel worth of the left and right sides of the screen is reserved for Windows system UI. You can't override this because if you did users would have no way of switching to another application.

    Well, technically, a user could switch via alt-tab, window-tab, directly clicking the running app in the task bar (if a desktop app), or directly clicking the running app in the Metro start area.  Regardless, the desire to kill the one-pixel ui element is a valid one.  Just as Aero Peek and other UI sugar can be disabled, so should this feature.

    Also, I've noticed this same question asked in a different thread and I apologize in advance for posting to both.  I've been unable to discover a solution via extensive web searches & an eyeball scan of likely registry entries.  If anyone does figure out how, I'd love to know- Starcraft 2 suffers dearly. :)

    Thanks!

    Wednesday, September 21, 2011 2:17 AM
  • I have  the same problem in Starcraft2 running in window mode, you just cannot scroll screen to the left using mouse )
    Wednesday, September 21, 2011 5:18 AM
  • Well, technically, a user could switch via alt-tab, window-tab, directly clicking the running app in the task bar (if a desktop app), or directly clicking the running app in the Metro start area.  Regardless, the desire to kill the one-pixel ui element is a valid one.  Just as Aero Peek and other UI sugar can be disabled, so should this feature.

    Those options aren't available on a tablet with no physical buttons, there has to be some reserved space for a touch sensitive UI.
    Wednesday, September 21, 2011 11:28 AM
  • Well, technically, a user could switch via alt-tab, window-tab, directly clicking the running app in the task bar (if a desktop app), or directly clicking the running app in the Metro start area.  Regardless, the desire to kill the one-pixel ui element is a valid one.  Just as Aero Peek and other UI sugar can be disabled, so should this feature.

    Those options aren't available on a tablet with no physical buttons, there has to be some reserved space for a touch sensitive UI.

    I agree with you on that, but those having this problem with Starcraft 2 (me included) are not using a tablet. May be that reserved space should be automaticaly disabled if windows detect a keyboard plugged in, or at least have an option to disable it only available when the user is using keyboard. I see it logical, since not everyone with Windows Developer Preview is currently running it on a tablet.
    Wednesday, September 21, 2011 9:28 PM
  • Well, technically, a user could switch via alt-tab, window-tab, directly clicking the running app in the task bar (if a desktop app), or directly clicking the running app in the Metro start area.  Regardless, the desire to kill the one-pixel ui element is a valid one.  Just as Aero Peek and other UI sugar can be disabled, so should this feature.

    Those options aren't available on a tablet with no physical buttons, there has to be some reserved space for a touch sensitive UI.

    I agree with you on that, but those having this problem with Starcraft 2 (me included) are not using a tablet. May be that reserved space should be automaticaly disabled if windows detect a keyboard plugged in, or at least have an option to disable it only available when the user is using keyboard. I see it logical, since not everyone with Windows Developer Preview is currently running it on a tablet.

    I wholeheartedly agree with Eukor. If a physical keyboard is detected there should be a way to disable the system UI reservation on the edges of the screen, preferrably manually tunable in the Control Panel. If someone over here can get this idea to the developers it would be really nice. I am sure such an issue can not and will not be ignored till release.
    Thursday, September 22, 2011 2:47 PM
  • StarCraft 2 is not the only game that suffers from this problem. I am also having this problem, and find it rather irritating it slows the reaction time on the game as well. Im sure there is a way to remove it but the way i have in mind is more of a permanent fix by deleting the windows ui pixel off the entire registry. However I would still like to have the option of using it later.
    Saturday, October 01, 2011 3:40 AM
  • I'm having this problem in most of my games.  It makes them unplayable. I'm considering uninstalling Win8 now so can I get back to enjoying games.

    I understand this is a developer preview, maybe I'll come back for the beta, hopefully this will be sorted by then.

    Monday, October 03, 2011 11:27 PM
  • One pixel worth of the left and right sides of the screen is reserved for Windows system UI. You can't override this because if you did users would have no way of switching to another application.

    I'm using a tablet with a mouse attached and I can see the effect of hitting the left hand 1px edge (the task switch thing) but none of the other edges seem to respond to the mouse hitting them. If they did remove the left 1px reservation I'm sure that the finger (sorry touch) method of swiping from off screen to on screen could still work? Tablet users still have the option of pressing the 'Windows' button (not sure if a hardware windows/home button is a requirement for all tablets?).

    I'm fairly sure my mac disables all active edges (hot corners) in full screen games, I cant see why MS cant do the same, maybe it will be an API option for game authors to select Full-full screen (ie disable all system ui hotspots/reservations etc.)


    Acer W500 tablet Ageing HP laptop Too much apple stuff
    Tuesday, October 04, 2011 4:54 PM
  • What I do is this...

    Open regedit. Navigate to HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Explorer

    Set the RPenabled value to 0 to disable the charm bar. Restart Explorer.exe and now the MetroUI will not steal focus when you're playing a game. An extra copyright message will appear on the desktop. You can also set RPenabled to 1 without restarting Explorer.exe and you will regain most of the good elements of the Metro UI without the Metro Start Screen popping up all the time Normal service is resumed on a reboot and I would assume a restart for Explorer.exe.

    This does seem to cause an issue with the file system refreshing explorer windows. Only way I can play Crysis 2 on Windows 8 though.

     

    Tuesday, October 04, 2011 5:36 PM