locked
FQDN configuration RRS feed

  • Question

  • How do I configure an FQDN on a machine that is Windows XP Pro and in a standalone workgroup using the loopback adapter for communications.  There is no DNS server and no DNS suffix.  There are no issues with communications as I can get back and forth from each instance to every other instance on this machine.  No security issues as they are all running under the same service account.  I'm using this for testing and demo purposes.  This was never an issue prior to SP2.  Now, I can't configure what I've always been able to run on this machine due to mirroring throwing an FQDN error when I try to start a mirroring session.  Without either DNS or a DNS suffix search list, there is nothing at all to configure.  So, how am I supposed to get a mirroring session to work, as it did previously?

    Friday, May 9, 2008 12:29 AM

Answers

  • Disregard, it is a bug.  The GUI does not work any longer for Database Mirroring if you have patch 3228 applied to your system.  The only way to get Database Mirroring configured is to execute the ALTER DATABASE statements from a query window.

    Friday, May 9, 2008 7:10 PM

All replies

  • Anyone?????????  Here's the error message:

     

    TITLE: Database Properties
    ------------------------------

    One or more of the server network addresses lacks a fully qualified domain name (FQDN).  Specify the FQDN for each server, and click Start Mirroring again.

    The syntax for a fully-qualified TCP address is:
    TCP://<computer_name>.<domain_segment>[.<domain_segment>]:<port>

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Here's the output for the relevant piece of ipconfig /all

    Windows IP Configuration

     

            Host Name . . . . . . . . . . . . : hotek

            Primary Dns Suffix  . . . . . . . :

            Node Type . . . . . . . . . . . . : Unknown

            IP Routing Enabled. . . . . . . . : No

            WINS Proxy Enabled. . . . . . . . : No

     

     

    Principal:  TCP://hotek:5022

    Mirror:  TCP://hotek:5023

    Witness:  TCP://hotek:5024

    Friday, May 9, 2008 6:40 PM
  • One other really weird thing is that if I'm using the GUI to initiate this, it is absolutely impossible to directly enter the Principal, Mirror, and Witness addresses.  Those fields are greyed out and will NOT enable.  The only way to get entries into the appropriate fields is to go through the configure security wizard.

     

    Name Internal_Value Character_Value
    ProductVersion 589824 9.00.3228.00

     

    Friday, May 9, 2008 6:43 PM
  • Disregard, it is a bug.  The GUI does not work any longer for Database Mirroring if you have patch 3228 applied to your system.  The only way to get Database Mirroring configured is to execute the ALTER DATABASE statements from a query window.

    Friday, May 9, 2008 7:10 PM
  • That is very interesting. Is that bug visible on Connect?

     

    Thursday, May 15, 2008 4:05 AM
  • Yes, it is.  The GUI was apparently crippled on purpose for scenarios where you were working with instances that were not members of a domain.  Apparently SQL Server 2008 now only throws a warning and allows you to continue, but SQL Server 2005 does not allow you to use the GUI to configure a mirroring session unless your instances are on machines within a domain.

    Thursday, May 15, 2008 4:10 AM
  • Here's the link to the actual page that has the TSQL example.

    One of the kickers is remember that if all instances are on the same server then the endpoints must use different ports...or so says the wizard that fails.
    Friday, August 1, 2008 2:25 AM
  •  

    Very interesting read.  I was curious Michael if you could have leveraged host files, entered a FQDN and then entered the domain name in the Primary DNS Suffix of the computer.    This may have forced the computers to think that the FQDN was present.

     

    Just a thought!!!

     

    Ross

    Friday, August 1, 2008 3:55 PM