none
Failed to connect to the database The Microsot.ACE.OLEDB 12.0' is not registered on local machine RRS feed

  • Question

  • I asked this question before. I thought it was fixed, but I am receiving this message whenever I try to connect an Access database. I have Windows 10 x64, Office Pro x64, and I installed AccessDatabaseEngine_X64. I re-installed Office and I re-installed the AccessDatabaseEngine_X64. I don't know how I can fix this.
    Wednesday, May 10, 2017 10:58 PM

All replies

  • Hi VBShaper,

    What's platform of your application?  I found some threads that advised changing the advanced compile configuration to x86 found in the programs properties if you're running a 64 bit system.

    And please take a look about Access Connection Strings:

    https://www.connectionstrings.com/access/

    Hope it is helpful to you.

    Best Regards,

    Cherry Bu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, May 11, 2017 2:18 AM
    Moderator
  • Hi VBShaper,

    What's platform of your application?  I found some threads that advised changing the advanced compile configuration to x86 found in the programs properties if you're running a 64 bit system.

    And please take a look about Access Connection Strings:

    https://www.connectionstrings.com/access/

    Hope it is helpful to you.

    Best Regards,

    Cherry Bu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    I tried to set it to X86, but that did not work. Thank you fro your answer.
    Thursday, May 11, 2017 9:39 AM
  • Try using the 32 bit Access database engine. Under the Compile tab in project properties use the following settings. This is what I've done and works with the 64 bit version of Office.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Thursday, May 11, 2017 11:17 AM
    Moderator
  • From where are you connecting? From the VS Data Designer? From code?

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Thursday, May 11, 2017 12:12 PM
  • No luck with prefer-32-bit. I have a feeling that the Microsoft Access Database Engine 2010 Redistributable is not installed even though I Uninstalled and reinstalled it several times. Is there a way to tell if it really is installed?

    Thursday, May 11, 2017 11:52 PM
  • From where are you connecting? From the VS Data Designer? From code?

    Paul ~~~~ Microsoft MVP (Visual Basic)

    I am using the designer.
    Friday, May 12, 2017 12:05 AM
  • From where are you connecting? From the VS Data Designer? From code?


    Paul ~~~~ Microsoft MVP (Visual Basic)

    I am using the designer.

    Visual Studio is 32-bit which means the Data Designer is 32-bit. You need to install the 32-bit ACE OLEDB Provider:

    https://www.microsoft.com/en-us/download/details.aspx?id=23734


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, May 12, 2017 2:08 AM
  • Hi VBShaper,

    Have you solve your issue now? if yes, please share your result here, it is very beneficial to the other communities who face the same issue.

    Thanks for your understanding.

    Best Regards,

    Cherry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 16, 2017 8:00 AM
    Moderator