none
PIP Message failed in PrivateInitiator Orchestration RRS feed

  • Question

  • My scenario is to post message from my application to trading partner. I am able to post PIP message succesfully to GetMessagesFromLOB from my application. After that LOB_To_PrivateInitiator picks to process and flow continue to PrivateInitiator Orchestration and get failed halfway. I tried debugging the Orchestration and found private process expecting signal from public process to post message to GetMessagesTOLOB but no signal from public process hence flow suspended with below error though pipcode, pipversion etc all set in previous orchestration step in PrivateInitiator Orchestration.

    Source module: 
    PublicInitiatorProcess   

    Correlation information: 

            PIP Code : NotSet 
            PIP Version : NotSet 
            PIP InstanceID: NotSet 
            SourcePartnerName : NotSet 
            DestinationPartnerName : NotSet 

    Description: 
    The type initializer for 'Microsoft.Solutions.BTARN.Shared.PerformanceCounters' threw an exception

    Please help.


    • Edited by DhanViji Tuesday, August 18, 2015 11:30 AM
    Tuesday, August 18, 2015 11:28 AM

All replies

  • Hi DhanViji,

    Have you look at the Event Log for more information or error detail, Are there any entries regarding your issue ?

    Could you try to RE-GAC the assemblies ?

    Please try to debug you code step by step and share the error information.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Sunday, August 30, 2015 8:18 PM