none
Workflow breakpoint error: The breakpoint will not currently be hit. Breakpoints cannot be set in code that is optimized or has no symbols when the debugger option ‘Just My Code’ is enabled. RRS feed

  • Question

  • Hi All

    I can debug the Workflows using Azure Service Bus ok, but if I add breakpoints they are never hit and paused. I would like to add breakpoints so the workflows pauses and I can get local variables and properties from the Watch Window. I have noticed a Workflow Breakpoints error:

    "The breakpoint will not currently be hit. Breakpoints cannot be set in code that is optimized or has no symbols when the debugger option ‘Just My Code’ is enabled."

    Can someone please tell me how to get Breakpoints working when debugging SharePoint Online workflows?

    I hope you can help,
    Colin

    Saturday, March 4, 2017 3:37 PM

Answers

  • HALLELUIAH !!!  I found the solution. I needed to untick:
      “Options > Debugging > General > Enable Just My Code”

    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:15 PM
    • Unmarked as answer by ceBlueSky Saturday, March 4, 2017 4:24 PM
    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:24 PM
    Saturday, March 4, 2017 4:15 PM

All replies

  • HALLELUIAH !!!  I found the solution. I needed to untick:
      “Options > Debugging > General > Enable Just My Code”

    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:15 PM
    • Unmarked as answer by ceBlueSky Saturday, March 4, 2017 4:24 PM
    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:24 PM
    Saturday, March 4, 2017 4:15 PM
  • Hi,

    Glad to hear that you solve this issue, thanks for your sharing.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 6, 2017 2:42 AM
    Moderator