none
pdb not loaded persistent problem

    Question

  • In visual studio 2012 I could step through my c# code with no problems. Now with 2015 I cannot because every time after I hit a breakpoint I get pdb not loaded or symbol file not found. I have read tons of solutions and forums but none solved the problem, have also tried all the settings available at debug settings. Is there a way to make the 2015 version behave like 2012? All I desire is to step through my c# code without these pages showing up. Help please!
    Wednesday, June 15, 2016 3:47 PM

Answers

  • Thanks for Ewald's help.

    Hi olhodolago,

    Before you debug your app, please enable the Symbol Servers.

    Please also use the debug mode, platform=X86 or others, re-build your app, debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by olhodolago Friday, June 17, 2016 1:47 PM
    Friday, June 17, 2016 9:38 AM
    Moderator

All replies

  • Can you tell more about your application - is it 'Windows Forms', WPF ...?
    And can you look up in 'Modules Window' (Debug->Windows->Modules), which symbol files are missing?
     
    Because normally, when breakpoint is hit, symbols for this module are loaded, could it be that you have problems with 'Step Over' (F10) or 'Step Into' (F11)?
    In the latter case would probably try 'Debug->Options...' 'Debugging->General 'Enable Just my Code'.

    With kind regards

    Wednesday, June 15, 2016 4:28 PM
  • Thank you for your attention, I finally feel like saving some hair now.

       It's an Universal App, and you're right, I get this when I step over or into. Most symbol files that do not load are non-user but about ten of them are user code, to name a few: App1.exe,UWPHost.dll,coreclr.dll,tiptsf.dll. I've tried 'Enable just my code' both checked and unchecked. The first page I get after stepping into is 'dependencyobject.cpp not found' .

    Regards


    • Edited by olhodolago Wednesday, June 15, 2016 5:57 PM
    Wednesday, June 15, 2016 5:44 PM
  • Universal App not my strength.
    One thing I would check: for unloaded symbols, if right click in 'Modules Window' then 'Symbol Load Information...' does it say not found or no match?

    With kind regards
    Wednesday, June 15, 2016 8:21 PM
  • Thanks for Ewald's help.

    Hi olhodolago,

    Before you debug your app, please enable the Symbol Servers.

    Please also use the debug mode, platform=X86 or others, re-build your app, debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by olhodolago Friday, June 17, 2016 1:47 PM
    Friday, June 17, 2016 9:38 AM
    Moderator
  • Thank you, Jack-Zhai,

        That solves the problem, I had to specify the location where to load symbols to.

                                                                                                              Regards.

    Friday, June 17, 2016 1:50 PM