none
xperf exception from xbootmgr rebootCycle trace RRS feed

  • Question

  • Hi,
    I'm having issues with xperf when it tries to look at a trace generated with
    xbootmgr -trace rebootCycle
    When I run
    xperf -i boot_BASE+CSWITCH_1.etl -a boot
    xperf returns the following:
    Time inversion was detected in the trace. Aborting processing.
    
    Traces with time inversion cannot be processed reliably because
    their very notion of time is broken. Time inversion is most usually
    caused by hardware timer wraparound in the absence of the ACPI
    driver, or trace corruption.
    
    If you want xperf to attempt to process this trace in the presence
    of time inversion, use the /tti (tolerate time inversion) option
    on the command line.
    Okay, fine so I ran
    xperf /tti -i boot_BASE+CSWITCH_1.etl -a boot
    and got the following:
    error:   EventSink {9931fec4-dfe3-4d2c-bc8c-a6b0f5e5b8f7} returned HRESULT 0x8000ffff on:
             Event#: 1130     (T#0:#1130)
             TimeStamp:   -1834815, Process:    4, Thread:   64, Cpu:   1
             ProviderId: {9c205a39-1250-487d-abd7-e831c6290539}
             EventDescriptor: 0x00de 0x00dc 0x02   0x00    0x10    0x04  0x4000000000010020
             UserDataLength: 66
    Execute: ISession::ProcessEvents [0x8000ffff]
    I'm using version Version 4.1.6512.  Anybody know how I can proceed with analyzing this trace?  If not any workaround suggestions?

    Thanks,
    Louis




    Wednesday, July 15, 2009 10:14 PM

All replies

  • Hi Louis,

    The /tti option is not guaranteed to work - it can deal with minor time inversions, but in your case you have a major time inversion so the trace is not usable. Are you hitting this issue reliably or is it only happening in this one trace?

    Thanks,
    Michael
    Thursday, July 16, 2009 3:28 PM
  • Hello Michael,

    I am hitting this issue reliably.  I've tried the same test on this machine 5 times now.  Can you expand upon this warning message?
    Time inversion is most usually caused by hardware timer wraparound in the absence of the ACPI driver
    Thanks,
    Louis
    Saturday, July 18, 2009 5:56 PM
  • Hmm.  No help?  Yikes.

    Tuesday, July 28, 2009 5:52 PM
  • Appologies for delay. It's conferences and planning time for us here :)

    Time inversions are either caused by h/w issues or BIOS issues. Are you running the latest version of the BIOS for this system? If not, we may need a copy of the trace to help further root-cause this.

    Thanks,
    Michael
    Friday, August 7, 2009 4:16 AM