none
unable to find run time version in .NET Framework 4.0 RRS feed

  • General discussion

  • I have XP home on 32 bit computer, with all updates. I was running MicrosoftFIXIT.printing, and was told I needed  .NET Framework 2.0 or above. I downloaded and installed   .NET Framework 4.0 [I understand 4.5 is not for XP Home]. Running MicrosoftFIXIT.printing, I got the message from  MATSBOOT.EXE saying .NET Framework was unable to find a version of run time. What does this mean?
    Sunday, August 19, 2012 9:30 PM

All replies

  • Hi mandyshop,

    It means the application cannot find a proper runtime to run.

    What's the Sp level on your machine?

    I'm not sure what can be the core error so please use the following tool to verify .NET Framework 4:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    What's more, please share the link of MS Fixit. 

    Thanks,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, August 21, 2012 5:44 AM
    Moderator
  • Change the status to "General Discussion"
    We are changing the issue type to "General Discussion" because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and click the button "Change Type" at the top of the post. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, September 4, 2012 7:57 AM
    Moderator
  • I know this is over 5 years later and @mandyshop is probably not going to see it, but others may pick this up on a search. My research on "MATSBOOT.EXE" shows that it only works with .NET Framework 2.0 or 3.5. The message mandyshop received said, "2.0 or above", but installing .NET 4.0 was too far above. Install only 2.0 or 3.5, (or, if I understand correctly, installing both will also work). 
    Sunday, December 10, 2017 8:57 PM