locked
HTTP Error 500.21 - Internal Server Error Handler "ScriptHandlerFactory" has a bad module "ManagedPipelineHandler" in its module list RRS feed

  • Question

  • User1326604821 posted

    Hi to everybody.

    I'm new to IIS + ASP and i need desperately yout help. I want to create WebService and use them via .asp WebPage. So, i create a WebServices dir to default IIS website directory(C:/inetpub/www/.....) and via VS 2008 (Hosting on Windows64bit - 7 Proffesional) create new web services application. The deafault , sayHello.

     So far so good......

    When i create a WebPage via .asp and add perform -->add Web Reference -->locate the WebService the following error come up:

      Handler "ScriptHandlerFactory" has a bad module "ManagedPipelineHandler" in its module list

    Google-it i found that the erorr could be in configuration of IIS but i can't find what is wrong???

    Thanks

    Monday, November 16, 2009 3:30 AM

Answers

  • User-1653247517 posted

    Try suggestions in this thread.

    Thanks,
    Kanwal

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 8:28 PM

All replies

  • User-1653247517 posted

    Try suggestions in this thread.

    Thanks,
    Kanwal

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 8:28 PM
  • User-660406550 posted
    Honestly I thought I was turning mad!!!! About this one... All I had to do was change Classic mode by integrated mode in IIS options, and that's working like a charm now! Hope it's useful for one of you out there! Peace.
    Friday, August 20, 2010 8:18 PM
  • User2138270523 posted

     I had the same problem to. What i did is I went to Control Panel>Programs & Features, select Microsoft .NET Framework 4 Extended  and clicked on repair.

    I hope this will help people who has the same problem.

    Thursday, October 20, 2011 3:05 AM
  • User99834501 posted

    I had the same problem but repairing  Microsoft .NET Framework 4 Extended  as advised worked ,, great save lot of time and headache

    Thnx

     I had the same problem to. What i did is I went to Control Panel>Programs & Features, select Microsoft .NET Framework 4 Extended  and clicked on repair.

    I hope this will help people who has the same problem.

    Friday, November 18, 2011 2:51 PM
  • User1057745854 posted
    I am building a web project application. I am getting the same error on debugging... I am working on windows server 2008 r2. And i dont get an option for repair with Microsoft .NET Framework 4 Extended. I have also changed the application pool of my application to integrated pool type and asp.net is also installed but still the error persists... please help me,...
    Tuesday, November 22, 2011 8:17 AM
  • User1057745854 posted
    I got the solution through this thread.. http://forums.iis.net/p/1149449/1869918.aspx I ran the following through run and my problem got solved... %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i
    Tuesday, November 22, 2011 8:55 AM
  • User855079157 posted

    This worked. I noticed in IIS, in the Application Pools, that I did not have:

    ASP.NET v4.0

    ASP.NET v4.0 Classic

    so running this:

    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    in my case C:\windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    This registered it, I restarted the website, and the website came up. Thanks SANEEHA

    Wednesday, July 31, 2013 1:03 PM
  • User798986801 posted

    Thank so much!

    Tuesday, September 17, 2013 11:19 PM