locked
My Cube is empty after processing - where did the data go? RRS feed

  • Question

  • Hello!

     

    I inherited a cube from another developer.  After working though it for awhile and fixing broken views etc, I am able to get the cube to deploy and process.  However, the cube appears to be empty.  I can retrieve no data from it at all.

     

    In Dev Studio, I can drill through the data source to see that the tables and views are actually populated, but nothing appears inside the cube.

     

    I have no idea where to look for the problem.  Any ideas would be appreciated!

     

    Thanks,

    Dave

    Tuesday, July 3, 2007 9:04 PM

Answers

  • Check the calculations tab in the cube. There should be a "calculate;" command (usually the first line) - if this command is not present in the calculation script data will only get appear at the leaf level of the cube (ie. every single dimensions would be have to set to a bottom level member in order to see any data)
    Wednesday, July 4, 2007 4:05 AM

All replies

  • When you say you can drill through "the data source" are you saying you can explore the data in the DSV specifically and see records being returned there? 

     

    If you can, try processing just a single dimension.  In the Process Progress dialog window, you can expand the nodes of each attribute in the dimension to see the SQL statement being submitted and the number of records returned. 

     

    If it appears data is coming back, close the dialog, move to the browse tab and reconnect to the instance.  You should now see data.  Repeat with other dimensions as needed.

     

    If you see data in all your dimensions, then it's time to move to the cube.  Process the cube in a similar manner.  Note the SQL statements and number of records. 

     

    Good luck,
    Bryan

    Tuesday, July 3, 2007 10:33 PM
    Answerer
  • Check the calculations tab in the cube. There should be a "calculate;" command (usually the first line) - if this command is not present in the calculation script data will only get appear at the leaf level of the cube (ie. every single dimensions would be have to set to a bottom level member in order to see any data)
    Wednesday, July 4, 2007 4:05 AM
  • That did it  !

     

    Thanks a bunch!

     

    Dave

    Wednesday, July 11, 2007 8:06 PM
  • Hi,

    Thanks a lot. It is Working.

    Problem:

    "I am able to get the cube to deploy and process.  However, the cube appears to be empty.  I can retrieve no data from it at all.In Dev Studio, I can drill through the data source to see that the tables and views are actually populated, but nothing appears inside the cube."

    Solution:

    Go to Calculations Tab->Inside this you will have Script View and paste below content if it is not there->Save and reprocess it.  

     

     /*

    The CALCULATE command controls the aggregation of leaf cells in the cube.

    If the CALCULATE command is deleted or modified, the data within the cube is affected.

    You should edit this command only if you manually specify how the cube is aggregated.

    */

    CALCULATE

     

    Friday, April 15, 2011 11:41 AM