none
Form controls are all messed up after migrating project in VS 2015 from VS 2013

    Question

  • I was working on a Windows Forms Application in VS 2013. I designed all the forms in Designer and every thing was looking great. I recently purchased VS 2015 and tried opening the same application in VS 2015 and the controls look overlapped and funky. 

    I also have changed the computer. If I open it in the old machine things look good. Any idea?

    

    Thanks,


    Tuesday, April 05, 2016 3:17 PM

Answers

  • Hi ImamM,

    >>I also have changed the computer. If I open it in the old machine things look good. Any idea?

    Do you also use the VS2015 in your old machine?

    (1)If you create a simple Winform app in your VS2015, how about the result? At least, we could know that whether it is related to the VS IDE.

    (2) As you said that it is the winform app created in old VS2013 version, whether it has certain custom controls or any third party library reference in your previous VS2013 machine?

    (3) Please clean and rebuild your solution in your VS2015, and then visit the output or Error list windows, please check that whether there are any error or warning messages.

    If a simple new winform app still has the designer issue, I suggest you repair your VS.

    But if just this one app has this issue, I think we would think about the project itself.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 07, 2016 4:09 AM
    Moderator

All replies

  • Hi ImamM,

    Thanks for your post.

    Windows Forms Designer Discuss features of the Windows Forms designer inside of Visual Studio as well as custom control designers and hosting the Windows Forms designer in your app. Since your issue is about vs design, I will move your thread to vs forum for better support.

    Thanks for your understanding.

    Regards,

    Moonlight


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, April 06, 2016 5:10 AM
  • Hi ImamM,

    >>I also have changed the computer. If I open it in the old machine things look good. Any idea?

    Do you also use the VS2015 in your old machine?

    (1)If you create a simple Winform app in your VS2015, how about the result? At least, we could know that whether it is related to the VS IDE.

    (2) As you said that it is the winform app created in old VS2013 version, whether it has certain custom controls or any third party library reference in your previous VS2013 machine?

    (3) Please clean and rebuild your solution in your VS2015, and then visit the output or Error list windows, please check that whether there are any error or warning messages.

    If a simple new winform app still has the designer issue, I suggest you repair your VS.

    But if just this one app has this issue, I think we would think about the project itself.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 07, 2016 4:09 AM
    Moderator