locked
VS2010 utimate installation fail in Win7 utimate RRS feed

  • Question

  • VC 9.0 Runtime (x86): [2] Error: Installation failed for component VC 9.0 Runtime (x86). MSI returned error code 1603

    [09/15/10,22:03:54] VC 9.0 Runtime (x86): ISetupManager::GetGlobalCustomProperty() failed to find global prop in CBaseComponent::GetGlobalCustomProperty()
    [09/15/10,22:03:54] Setup.exe: GetGlobalCustomProperty - Property: {BBE1827C-F2FD-4FDA-A6D6-C83B62FFFDCA} - PropertyName: compfailed - Value: 0
    [09/15/10,22:03:54] VC 9.0 Runtime (x86): CMsiComponent::Install(): Validating files.
    [09/15/10,22:03:54] Setup.exe: GetGlobalCustomProperty - Property: {E0875D42-A33D-4C64-81C9-167795F29CA4} - PropertyName: PathFromCartmanToRoot - Value: ..
    [09/15/10,22:03:54] Setup.exe: GetGlobalCustomProperty - Property: {E0875D42-A33D-4C64-81C9-167795F29CA4} - PropertyName: PathFromCartmanToRoot - Value: ..
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Looking for InstallPackage at vc_red.msi
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Looking for InstallPackage at C:\Users\ADMINI~1\AppData\Local\Temp\IXP0092D.tmp\wcu\vc90sp1\vc_red.msi
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Looking for InstallPackage at f:\setup\..\wcu\vc90sp1\vc_red.msi
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Found f:\wcu\vc90sp1\vc_red.msi
    [09/15/10,22:03:56] Setup.exe: GetGlobalCustomProperty - Property: {A17A8E79-CB1C-49DB-B92E-34ADBFCDA36B} - PropertyName: Patch List - Value:
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Command Line before token replacement.
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): USING_EXUIH=1 REBOOT=ReallySuppress
    [09/15/10,22:03:56] Setup.exe: GetGlobalCustomProperty - Property: {BD495746-4FBA-49F3-8EEB-D8B20EE75235} - PropertyName: Disable Rollback - Value:
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): MSIComponent Action: Installing MSI f:\wcu\vc90sp1\vc_red.msi with command-line: USING_EXUIH=1 REBOOT=ReallySuppress
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): (MsiRetryHelper) calling EnableMsiLog() function now.
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): Enabling MSI log file: C:\Users\ADMINI~1\AppData\Local\Temp\dd_VC_Red_MSI0934.txt
    [09/15/10,22:03:56] BWaitForMSI(): Verifying we're the only installation currently in progress.
    [09/15/10,22:03:56] BWaitForMSI(): Ready to proceed with installation.  Continuing...
    [09/15/10,22:03:56] VC 9.0 Runtime (x86): (MsiRetryHelper) calling MsiInstallProduct() now.
    [09/15/10,22:04:45] VC 9.0 Runtime (x86): MSI Record result detail: Error 1935.An error occurred during the installation of assembly 'policy.9.0.Microsoft.VC90.MFC,version="9.0.30729.4974",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86",type="win32-policy"'. Please refer to Help and Support for more information. HRESULT: 0x800736B3.
    [09/15/10,22:04:45] VC 9.0 Runtime (x86): MSI Record result detail error code: 1935
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): Action returned 1603/1935 - Retry counters:
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1618: 0/100
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603: 1/0
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1303: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1306: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1308: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1309: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1310: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1311: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1329: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1330: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1335: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1406: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1706: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/1719: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): 1603/25543: 0/2
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): Will not retry.
    [09/15/10,22:05:09] InstallReturnValue: GFN_MID Chained VC 90 Runtime for x86, 0x643
    [09/15/10,22:05:09] Setup.exe: GetGlobalCustomProperty - Property: {B7D05DBA-FC13-4B6C-B30E-28967A0FFF4E} - PropertyName: Reboot Count - Value: 1
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): Reboot Counter = 1
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): This component HAS already request a reboot prior to installation.
    [09/15/10,22:05:09] Setup.exe: AddGlobalCustomProperty
    [09/15/10,22:05:09] Setup.exe: AddGlobalCustomProperty
    [09/15/10,22:05:09] VC 9.0 Runtime (x86): ***ERRORLOG EVENT*** : Error: Installation failed for component VC 9.0 Runtime (x86). MSI returned error code 1603
    [09/15/10,22:05:09] Setup.exe: GetGlobalCustomProperty - Property: {BBE1827C-F2FD-4FDA-A6D6-C83B62FFFDCA} - PropertyName: compfailed - Value: 0

    • Moved by Sheng Jiang 蒋晟 Wednesday, September 15, 2010 6:15 PM (From:Visual Studio 相关讨论(Visual Studio 2010以前版本))
    Wednesday, September 15, 2010 2:44 PM

Answers

  • I reinstall WIN7 from local driver, then install VS2010 on the clean system. After is successes, I install the drivers and applications

    Now It's OK, Thanks a lot

    • Marked as answer by billb08 - MSFT Thursday, September 30, 2010 12:07 PM
    Wednesday, September 29, 2010 2:49 PM

All replies

  • 单独安装vc_red.msi和vc_red.cab。出现错误

    msiexec /i vc_red.msi USING_EXUIH=1

    HRESULT: 0x800736B3 error 1935

    Wednesday, September 15, 2010 3:27 PM
  • After I reinstall win7, I met the same error when installing vs2010
    Wednesday, September 15, 2010 3:32 PM
  • Hello,

    You may try the following setps to see if they help:

    1. Verify that if you have turned on the feature of .NET Framework.
        (Control Panel - Programs and Features - Turn Windows features on or off - Verify that the box next to Microsoft .NET Framework has been checked)

    2. Use Verification Tool to verify .Net Framework has been installed well on your OS. If .Net Framework cannot be verified on your computer, you can try to follow the steps mentioned in this blog to repair the .NET Framework.

    If the installation still fails, I think we need to collect the logs for further troubleshooting. After collecting logs, you may send vslogs.cab file to me (v-jinfan@microsoft.com)

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install VS2010
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, September 16, 2010 5:56 AM
  • Thanks for your response.

    I have checked the 2 steps and .NET Framework has been installed well, but the installation still fails. And I have collected the vslogs.cab and send mail to you (v-jinfan@microsoft.com)

    Thursday, September 16, 2010 3:33 PM
  • Hello ktty,

    Could you please send it again and add a link to this post in the mail please? I can not figure out which mail is related to this post.

    Thanks.


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Friday, September 17, 2010 5:45 AM
  • Actually I have written down the link of this post, please check.And now I am waiting my flight in the airport, I'm too sorry to send the email again. My email is ssbing@msn.com.
    Friday, September 17, 2010 12:28 PM
  • Hello Edwer Fang [MSFT]

    Could you please give me the solution? Thanks

    Sunday, September 19, 2010 12:02 PM
  • Hello,

    As I can see from the log, you may try following setps to see if they help:

    Workaround 1:

    Reboot your machine and restart Visual Studio 2010 setup.

    Workaround 2:

    If Workaround 1 doesn’t work,

    1. Reboot the machine

    2. Disable windows update (start menu -> windows update)

    3. Restart VS setup

    4. When VS Setup is done, enable windows update (don't forget this step!)

    If they not help, have you installed previous version of Visual Studio on your machine? If so, please uninstall according to the following articles: http://msdn.microsoft.com/en-us/library/ms246604(VS.80).aspx http://msdn.microsoft.com/en-us/library/ms246604(VS.90).aspx


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Wednesday, September 22, 2010 3:21 AM
  • Hello

    I have tried workround1 and workround2, and I haven't install previous Visual Studio. But when I install VS2008, it success.

    But why?

    Wednesday, September 22, 2010 11:13 AM
  • Hello,

    Based on the log, this issue is cased by Windows Upate issue.

    So are you able to install VS2010 now?


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, September 23, 2010 7:15 AM
  • Hello, unfortunately, the answer is no. I'm crazy now.

    In order to install VS2010, I unistall VS2005, then reinstall win7, and have tried so many times. It always fails.

    Thursday, September 23, 2010 4:09 PM
  • Hello,

    Based on your descriptions, this issue still exists even after you reinstall WIN7, well, how do you install it? If you install it with DVD drive, you may create an ISO image of the CD/DVD, Once the ISO image has been created, either:
    * Extract the ISO image, to your local computer, that you have just created using something like ISOBuster and run the installation from the harddrive/harddisk
    * Mount the ISO image to a virtual CD drive, using another 3rd party tool something like MSVCD, and run the installation from here

    If the above steps still do not work, try to install it on a different computer. Does it work? if not, most likely the media could be faulty/damaged in which case you need to go back where you obtained the product from and explain the situation. They should be able to help you.


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • Proposed as answer by Sanjeev.Kumar Friday, September 24, 2010 4:32 AM
    Friday, September 24, 2010 3:08 AM
  • However, I install VS2010 in another PC which OS is WIN7, everything is OK and no need reboot

    And I always copy the VS2010 in a directory and install it

    Thanks a lot

    Friday, September 24, 2010 10:13 PM
  • It looks like you are not able to install Visual studio because of corrupted VC Runtime install and its library

    Please run uninstall tool to remove all prerequisites,

    http://code.msdn.microsoft.com/vs2010uninstall/Release/ProjectReleases.aspx?ReleaseId=4321

    Tuesday, September 28, 2010 6:42 PM
  • I reinstall WIN7 from local driver, then install VS2010 on the clean system. After is successes, I install the drivers and applications

    Now It's OK, Thanks a lot

    • Marked as answer by billb08 - MSFT Thursday, September 30, 2010 12:07 PM
    Wednesday, September 29, 2010 2:49 PM