locked
Arabic numbers display problem when export to PDF RRS feed

  • Question

  • User326681626 posted

    I'm working in an ASP.net web application. I'm trying to export a crystal report file (.rpt file) to pdf viewerthe following code:

     

     CrystalDecisions.CrystalReports.Engine.ReportDocument doc = new CrystalDecisions.CrystalReports.Engine.ReportDocument();

            doc.Load("C:\\Users\\amino\\Documents\\Visual Studio 2005\\WebSites\\WebSite1\\Report.rpt");

            CrystalReportViewer1.ReportSource = doc;
            CrystalReportViewer1.Visible = true;

            MemoryStream oStream; // using System.IO
            oStream = (MemoryStream)doc.ExportToStream(CrystalDecisions.Shared.ExportFormatType.PortableDocFormat);
            //oStream = (MemoryStream)doc.ExportToStream(CrystalDecisions.Shared.ExportFormatType.WordForWindows);
            Response.Clear();
            Response.Buffer = true;
            //Response.Write("<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" />");
            Response.ContentEncoding = System.Text.Encoding.UTF8;
            Response.Charset = "UTF-8";
            Response.ContentType = "application/pdf";
            Response.BinaryWrite(oStream.ToArray());
            Response.End();

     

    When the pdf viewer opens, numbers should be displayed in arabic because in the rpt file numbers are displayed in arabic format. What happens is when pdf viewer opens, I have the arabic numbers displayed in english!!!

    can anyone help me to solve this problem? I can't find any solution for it on the internet.

    Sunday, February 7, 2010 5:40 PM

Answers

  • User771898575 posted

    check the link
    http://www.datadynamics.com/forums/128653/ShowPost.aspx


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 12:22 AM

All replies

  • User771898575 posted

    check the link
    http://www.datadynamics.com/forums/128653/ShowPost.aspx


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 8, 2010 12:22 AM
  • User326681626 posted

    Thank you amanbhullar for your reply.

    I already saw this topic before and tried it but it was not working :( . Beside that this topic using Active Report as reporting tool not crystal reports. 

    Monday, February 8, 2010 2:20 AM
  • User-672042310 posted

    I have the same problem too so did you solve it or still becuase i ididn't solve it until now ??????? :s

    Saturday, April 3, 2010 2:31 AM