locked
Exception from HRESULT 0x89721200 RRS feed

  • Question

  • Hello,

    I am suffering a problem trying to use the Apllication Deployment tool.

    Everytime i open the toll it gives me the Error: Exception from HRESULT 0x89721200.

    I tried to reinstall the whole developing stuff like visual studio express 2012 for windows phone, but i couldnt get it to work.

    I am able to deploy projects in VS to my WP8 but i can not deploy xap files through this tool.

    I hope somebody can tell me where this is coming from or how to fix the issue.

    best regards,

    Philipp

    Tuesday, December 18, 2012 11:46 AM

Answers

All replies

  • I have the same problem, someone can help us?
    Thanks!

    Vicente Guzman | Windows Phone VIP Ex-Microsoft Student Partner @LucioMSP

    Tuesday, December 18, 2012 10:58 PM
  • Hi,

    so you try to follow the instructions like mentioned in here:

    How to deploy an app using the Application Deployment tool for Windows Phone
    http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff769512(v=vs.105).aspx

    What type of "registered (?)" device do you use?

    Do you get his error independent of the XAP file / Project?

    What dev hardware do you use?
    Have you tried to use a different USB port?
    You might also check if there or USB port related updates available for your dev PC or check which USB configuration options can be set within the BIOS.

    Please let me know if you could do any progress.

    Thank you

    Klaus


    Klaus Bassler

    Wednesday, December 19, 2012 4:29 PM
    Moderator
  • Thank you for your reply, 

    I'm using a Lumina 920 registered for developing. As described the error occurs right after i start the application before im even able to select a xap file.

    I can deploy projects using visual studio express 2012 for WP but as far as i know i cant use it to deploy ready xap files, and thats what i need the deployment tool for. SO thats why iI think its a problem of the tool itself and has nothing to do with the hardware..

    I did try to have my phone connected to diffrent ports before starting the tool but no diffrence.

    Philipp

    Wednesday, December 19, 2012 5:45 PM
  • Exactly the same error here.
    • Proposed as answer by joergg1234 Thursday, January 3, 2013 3:02 PM
    • Unproposed as answer by joergg1234 Thursday, January 3, 2013 3:02 PM
    Saturday, December 22, 2012 7:51 PM
  • Is there a solution? I have the same Problem!
    Thursday, January 3, 2013 3:02 PM
  • Is there a solution? I have the same Problem!
    I still did not get any information on how to fix this problem :(
    Thursday, January 3, 2013 11:22 PM
  • This Problem have also other People in other Forums :(

    I installed SDK 7.1 and the update 7.1.1 - this is working. But I have also the Options if I start a new project to devolop for 7.0 and 7.1.

    Where is the 7.5 Option?

    In SDK 8.0 there is the Option 7.1 and 8.0. Where is 7.5? Is this a bug? How is it by you?

    Friday, January 4, 2013 9:40 AM
  • It's a bit confusing, but target 7.1for 7.5 phones.
    Friday, January 4, 2013 6:15 PM
  • I got a solution now, my problem was the German version of the SDK.

    I removed the German version and installed the English SDK, now everything is working fine.

    Hope this also helps you.

    • Proposed as answer by Cyber.Cat Thursday, January 31, 2013 8:45 AM
    • Marked as answer by lippl Tuesday, February 5, 2013 10:47 PM
    • Unmarked as answer by lippl Tuesday, February 5, 2013 10:48 PM
    • Unproposed as answer by lippl Tuesday, February 5, 2013 10:49 PM
    Thursday, January 31, 2013 8:45 AM
  • Hi Space!

    If you got this error, than it has to do with the language settings of your computer.

    For example: German SDK installed, but when you live in Austria (which ist NOT Germany! (and by the way we don't have kangaroos ;-)) and your language settings are set to "Austria" than you will get this error. If you switch the settings to "Germany" you can start the delployment tool. Just that easy!

    It is because we spoke german, but have different date, time, etc. settings.

    (Germany = de-DE, Austria = de-AT).

    This is the same problem as when you try to install the german version of SQL Server on a system with austrian settings. Why Microsoft is not able to fix this / do it right - I don't know.

    Greetings from Austria!

    • Proposed as answer by yellowcup333 Monday, February 4, 2013 5:21 AM
    • Marked as answer by lippl Tuesday, February 5, 2013 10:48 PM
    • Unmarked as answer by lippl Tuesday, February 5, 2013 10:48 PM
    • Unproposed as answer by lippl Tuesday, February 5, 2013 10:49 PM
    Saturday, February 2, 2013 1:21 PM
  • you are right!!!!

    Sunday, February 3, 2013 10:18 AM
  • change the system region format's language as same as your sdk's language 
    Sunday, February 3, 2013 10:19 AM
  • Hi, 

    I have the same error : Exception from HRESULT: 0x89721200

    I checked the language issue and it seems ok!

    • In Windows 8 Region, Format : Français (France)
    • Microsoft .NET Framework 4.5 SDK - Module Linguistique FRA
    • Windows Phone SDK 7.1 - Français

    But I still have this error on my WP7 project... 

    Do you have any idea to help me?

    Monday, April 1, 2013 1:15 PM
  • I had the same issue on my W8 Tab, HTC One, WP8 in Austria. I have configured the following:

    - Controlpanel -> Time, Language and Region -> Region -> Tab Manage -> Changed Location to Germany (from de-AT to de-DE)

    - Controlpanel -> Time, Language and Region -> Language -> Language Settings -> Move Germany to the Top (German Austra was active)

    Sicherheitshalber hier nochmal auf Deutsch, da ich mir bei den englischen Menüpunkte nicht sicher bin:

    - Systemsteuerung -> Zeit, Sprache und Region -> Region -> Tab Verwaltung -> Gebietsschema ändern

    - Systemsteuerung -> Zeit, Sprache und Region -> Sprache -> Deutsch (Deutschland) nach oben

    Installed Software:

    - .NET + Updates

    - Zune

    - VS Express for Windows Phone

    - Windows Phone SDK 8.0

    Unlock the Windows Phone 8:

    - Start -> All Apps -> Windows Phone SDK 8.0 -> Windows Phone Developer Registration

    Monday, April 22, 2013 10:27 PM
  • Have you used some software to modify the phone such as "Windows Phone Hacker"?
    Thursday, April 25, 2013 8:23 PM
  • Hi

     Ok, nice men thats very possible

    But you know what men Im tired of microsoft and your fucking errors, I'm really tired, they dont pay us for 

    test your funcking software I really tired of that sheet.

    Fixing microsoft bugs all time instead real programming.

    Very good for our friend who perhaps found a solution but we're paying for a complete product not 

    for a beta version.

    Bill with a lot of money need to hire more people to test your funcking sheet. We're not testers

    I'm dev no tester, I just want a simple hellow world and I spent all day fixing your fucking microsoft bugs.

    Bill you know what , do you know the word QUALITY.? 





    • Edited by user1one Friday, March 7, 2014 6:48 AM
    Friday, March 7, 2014 6:36 AM