locked
Information Bar blocks My Computer RRS feed

  • Question

  •  

    Whenever I try to run html files from folders on my PC the dam info bar bitches at me about security. In order to view my page I always have to click the bar, then tell it "yes, allow the blocked content", and then another box pops up "are you sure?" and once again I must answer "yes, dammit run the thing already!!!". These are simple html files I've created that are sitting on my PC and do not access the internet in any way. They aren't even sitting on a shared network drive, they just exist in some local folder on my PC. All they do is run very simple DHTML javascript functions like hiding text, changing colors or fonts, handling mouse clicks, doing some page init onload, etc, or sometimes they may contain some ActiveX object which is already installed on my system, or use a Front Page feature. None of them even have any hyperlinks in them. They are certainly not a security risk by any stretch of the imagination.

     

    I have followed the instructions in the Info Bar to try and turn it off for my local intranet zone but that does not disable the Info Bar. My local intranet zone is set to Lowest security in the Internet Options. The zone identified at the bottom of the MSIE window is My Computer though not Local Intranet. The only way I've found to stop this annoying blocking of files on my own system is to start up a web server and put the files into my local site folder. But I don't want to be running a web server just so I can run files from my own PC folders, nor do I want to have to put all the html files on my system into one specific folder. I want to organize them anywhere on my PC in any folder I choose and just not have them blocked in any way.

     

    Does anybody know how I can tell MSIE to avoid blocking local files in the My Computer zone?

    Saturday, December 22, 2007 4:47 AM

Answers

  • For files on the local computer... if you want to load them in IE, you'll need to add the MOTW (Mark Of The Web).

    Since IE's JScript can do a lot of real damage to the core file system, only files "marked" as safe are allowed.

    Add the MOTW to your pages and you'll be just fine.  (or just open the pages in any other  good browser like Firefox, Opera, or Safari)

    http://msdn2.microsoft.com/en-us/library/ms537628(VS.85).aspx
    Monday, January 7, 2008 6:01 PM

All replies

  • Bump.

     

    Monday, January 7, 2008 4:34 PM
  • For files on the local computer... if you want to load them in IE, you'll need to add the MOTW (Mark Of The Web).

    Since IE's JScript can do a lot of real damage to the core file system, only files "marked" as safe are allowed.

    Add the MOTW to your pages and you'll be just fine.  (or just open the pages in any other  good browser like Firefox, Opera, or Safari)

    http://msdn2.microsoft.com/en-us/library/ms537628(VS.85).aspx
    Monday, January 7, 2008 6:01 PM
  • Awesome. Exactly what I was looking for. Thanks.

    Wednesday, January 9, 2008 5:02 AM
  •  

    There is a direct way to tell IE to stop blocking My Computer files: go to Tools/Internet Options/Advanced and check the box titled "Allow active content to run in files on My Computer".
    Monday, January 14, 2008 8:32 PM