none
Excel file under TFS Source Control is auto checked out when double clicked - how can this be disabled

    Question

  • This problem appears to be related to the settings/preferences on one individual's workstation (either in VS2012 or in Excel 2010).

    This user navigates to the Excel file in source control explorer and double-clicks it and it opens in edit mode and is automatically checked out. The user does not experience this behavior with other file types which leads me to believe the issue is not with VS.

    This is not the behavior that is experienced by all other users and even this user on a different workstation.

    The expected behavior is for the file to open in read only mode (which is true for all but this one workstation).

    I've checked the Source control environment options and they are set to the default values.

    Is there a preference/option in Excel that could be responsible for this behavior?

    Wednesday, June 22, 2016 2:57 PM

Answers

  • Finally fixed this issue....

    This user recently received a new workstation (part of the migration to Windows 10), a fresh install of Office and Visual Studio.....and the problem still existed (auto checkout when opening a pdf or xls file).

    I am still uncertain how this happened but we narrowed it down to the workspace.

    Test:

    We created an alternate workspace and a few mappings then tried to reproduce the problem....we did not see the "Auto-Checkout" when opening pdf or xls files located in the new workspace.

    Solution:

    1.) Remove the old workspace and ensure that the mappings and any local file structure associated with the old workspace are completely gone.

    2.) Create a new workspace and mappings, get latest, and you should be good to go.

    Cheers,

    Jeff


    • Marked as answer by The_Def_J Wednesday, January 25, 2017 11:23 AM
    • Edited by The_Def_J Wednesday, January 25, 2017 11:24 AM
    Wednesday, January 25, 2017 11:23 AM

All replies

  • Hi The_Def_J,

    Thanks for your post.

    Please right click the excel file in the source control explorer then click view. Does it have the same problem?

    Generally the double-click the excel file equals to click the view. And from your description. This strange behavior only occured for this user.

    Please suggest him to reset the setting of his Visual Studio then try it again.(Tools->Import and Export settings).

    >>Is there a preference/option in Excel that could be responsible for this behavior?

    As far as I know. There is no such option or setting can affect this. To validate whether the casue is in the excel file. You can test it using this excel as well.

    Best Regards,

    Lake Xiao

    Thursday, June 23, 2016 3:45 AM
    Moderator
  • Lake,

    Thanks for the reply.

    I have some additional information....Looks like the file extension ".xls" may not be associated correctly on this user's workstation.

    On this particular workstation with the problem:

    Double-clicking on a file with a .xls extension in TFS source control automatically checks out the file and opens it with Excel in edit mode (unexpected behavior).

    Double-clicking on a file with other extensions i.e. .xlsx, .xlm, etc...does not auto checkout and the file opens with Excel in read only mode (expected behavior).

    I'll check this workstation's file associations and ensure that the .xls extension is associated with Excel and if that doesn't fix it I'll try resetting all environmental settings. I'll post again with the results.

    Cheers,

    Jeff

    Thursday, June 23, 2016 3:35 PM
  • Hi Jeff,

    Thanks for your response.

    If you have any update, please feel free to let me know.

    Best Regards,

    Lake Xiao

    Friday, June 24, 2016 2:00 AM
    Moderator
  • Hi Lake,

    Sorry for the late reply.

    I've verified that the file associations on this user's workstation (that is experiencing the problem) are the same as other workstations (that are not experiencing the problem).

    We did experience the same problem when right-clicking on the file in source control and selecting 'View'.

    We have also tried resetting Visual Studio settings on the problem workstation to no avail.

    I don't think the problem is with the actual .xls file because the problem does not happen when other users open the same file from other workstations (opens in 'read only' mode and is not checked out automatically as expected).

    I can't believe that Visual Studio and/or Office would have to be reinstalled to fix this problem. If it isn't a preference or setting in Excel or Visual Studio, the registry would be the next place I would suspect but it is just a guess at this point.

    My workaround, in the future, is to simply save these files as .xlsx but that doesn't help this user and the plethora of .xls files that are currently in TFS source control.

    Cheers,

    Jeff

    Thursday, June 30, 2016 12:13 PM
  • Hi Jeff,

    I can't reproduce your problem even I used the .xls file. How about creating a new .xls file or .xlsx file and add to the source control. Does it have the same problem?

    I also think this is not related to the Visual Studio. Also since other users can view the .xls file successfully. So the cause is not in the .xls file as well.

    I don't know why it has this problem. Repairing Visual Studio is not a good method, but you could ask him to try it.

    Best Regards,

    Lake  Xiao

    Thursday, June 30, 2016 2:26 PM
    Moderator
  • Finally fixed this issue....

    This user recently received a new workstation (part of the migration to Windows 10), a fresh install of Office and Visual Studio.....and the problem still existed (auto checkout when opening a pdf or xls file).

    I am still uncertain how this happened but we narrowed it down to the workspace.

    Test:

    We created an alternate workspace and a few mappings then tried to reproduce the problem....we did not see the "Auto-Checkout" when opening pdf or xls files located in the new workspace.

    Solution:

    1.) Remove the old workspace and ensure that the mappings and any local file structure associated with the old workspace are completely gone.

    2.) Create a new workspace and mappings, get latest, and you should be good to go.

    Cheers,

    Jeff


    • Marked as answer by The_Def_J Wednesday, January 25, 2017 11:23 AM
    • Edited by The_Def_J Wednesday, January 25, 2017 11:24 AM
    Wednesday, January 25, 2017 11:23 AM