none
work with unicode chars in database? RRS feed

  • Question

  • I'm using the Database created with the Assistant manager for data of the visual studio 2013, And when i set the data the unicode chars saves a "?", instead the char, how can I solve that?. already I change the string to varchar data type in the database, and still saving the "?"
    One more thing, the database do not create physically the data is cleared when the application closes

    a good example to how use the database created in visual studio assistant?

    and Why the database is not saved, when the app exit?

    Saturday, January 31, 2015 6:41 PM

Answers

  • Hello,

    Considering that your database is created from the Visual Studio, it should a SQL Server database, if so, please have a try to set the column type to be one of them:

    nchar

    nvarchar

    ntext

    They are three types which supports Unicode characters, for details, please refer to this link:

    Using Unicode Data

    >> a good example to how use the database created in visual studio assistant?

    For this, since it is more related with the usage of Visual Studio, I suggest that you could ask it on the Visual Studio forum.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 2, 2015 9:52 AM
    Moderator

All replies

  • You really need to give more details.

    If you created the database using VS 2013 I have to assume that it is a SQL Server database.  Is the database file attached to the database or is it attached only for the purposes of processing?  What could be happening is that you create the file, that file is copied and used each time you test, so it will seem that no information is being stored (but again - no code no idea).

    As for the ? without more details (code please) it is impossible to help you.


    Lloyd Sheen

    Sunday, February 1, 2015 10:30 PM
  • Hello,

    Considering that your database is created from the Visual Studio, it should a SQL Server database, if so, please have a try to set the column type to be one of them:

    nchar

    nvarchar

    ntext

    They are three types which supports Unicode characters, for details, please refer to this link:

    Using Unicode Data

    >> a good example to how use the database created in visual studio assistant?

    For this, since it is more related with the usage of Visual Studio, I suggest that you could ask it on the Visual Studio forum.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 2, 2015 9:52 AM
    Moderator