PowerView SQL 2012 SP1 CU4 cannot connect to dimensional (metadata version 1.1)

All replies

  • We're having this problem too. May have to contact Premier support.

    • Edited by VincentCO Friday, September 06, 2013 2:16 PM
    Friday, September 06, 2013 2:06 PM
  • I'm having the same problem .. just upgraded to SQL SP1 CU4 and getting the same error message

    Had to kick into SQL Profiler before I got a meaningful error message though

    Errors in the metadata manager. The current model can only be expressed when the client is requesting tabular view metadata with VERSION restriction of 2.0 or later.

    Martin Hatch
    MCPD & MCITP SharePoint 2010
    MCTS WSS 3.0 | MOSS 2007

    Monday, September 16, 2013 9:15 AM
  • Have you installed the CU4 package on all the relevant servers?

    • SQL SSAS server (hosting the cube)
    • SharePoint / SQL SSRS back-end server
    • SharePoint WFE (where the SSRS Add-In is installed

    You need to have it installed in all 3 locations before it will work

    Martin Hatch
    MCPD & MCITP SharePoint 2010
    MCTS WSS 3.0 | MOSS 2007

    Monday, September 16, 2013 10:00 AM
  • I've single box install of SharePoint with all components at one place. Have applied SP1 CU4 and couldn't get it working. I keep getting error message of

    There were errors found while validating the page:

    • The database is not using in memory storage engine

    Any ideas??

    Thursday, October 10, 2013 3:49 AM
  • Have figured out the issue ... no problems now :-)
    Thursday, October 10, 2013 4:18 AM
  • How do you make this work?

    Can you give some details about it?


    Tuesday, February 25, 2014 6:44 PM
  • Hi

    Can you please elaborate on your issue and especially the solution?

    I am stuck with the same issue.

    Wednesday, March 05, 2014 1:17 PM
  • Hi,

    I solved this by running the full SQL 2012 SP1 CU4 package on all WFE servers in the farm. The current SQL Server 2012 SP1 Reporting Services Add-In for SharePoint doesn't exist in the CU4 build so there is a mismatch in versions. However by running the full CU4 package on the WFE servers it upgrades the Add-In to the correct version and you should be able to run PowerView with multidimensional cubes.

    Kind Regards


    • Proposed as answer by Daniel Glantz Tuesday, March 18, 2014 7:09 AM
    Friday, March 14, 2014 1:37 PM