Override system set font. RRS feed

  • Question

  • Hey!

    I just sent out my software to Beta testers and they showed me screenshots and it seems like their selected system font is appearing all over my app......ecckkk...

    This is in Win7 with a WPF app.

    I have almost all the fonts set to Segoe UI inside Blend for my app.
    Then I embedded it into the app using the font manager in Blend and it seemed to fix 10% of the text, but the rest is still his font.

    How can I set my app to never use a system set font and only use mine?




    Monday, December 6, 2010 12:48 PM

All replies

  • Here is an msdn page on including fonts:

    Monday, December 6, 2010 2:44 PM
  • Your app will display the system font if it can't find the font you have specified.  My advice is to double check all of the Uris for the fonts to make sure they are pointing to the embedded font.

    Tuesday, December 7, 2010 12:18 AM
  • Ok, gonna check this out.

    will let you know if I can fix it.

    Shouldn't all Win 7 systems have Segoe UI  installed?
    I thought that was the default system font




    Tuesday, December 7, 2010 11:20 AM
  • Ok, so it's not a question if the font is installed.

    The user does have it. He changed it by going to Control Panel\Appearance and Personalization\Personalization\Window Color and Appearance

    and clicking the "Advanced appearance settings" and pops up a very old school window and he changed the Messagebox to the  Consolas Font

    So the question now goes from how to include fonts to "How do I block user settings like this and force my WPF app to use the font I selected"

    What I'm doing now is changing the font from something else and then back to SegoeUI so that the little white square is lit up next to the font in Blend and it's fine now.

    It's taking a while but does work........8)




    Tuesday, December 7, 2010 12:52 PM