none
Visual Studio 2015 Hanging with Not Responding

    Question

  • I've been having a lot of trouble with Visual Studio 2015 randomly hanging with a Not Responding message. This happens several times an hour, each hang might last from 20 to 60+ seconds. This has become a major productivity issue for me.


    I see this occasionally when saving, building, loading solution and especially when documenting with the GhostDoc extension (Ctrl-Shift-D) (even a single property). I've seen this in SafeMode and I've tried logging which doesn't show anything during the hang. I've even fully reinstalled the application.


    I've been monitoring Resource Monitor like a hawk. Each time this happens the devenv.exe process is shown as not responding and the Analyze Wait Chain dialog always shows "One or more threads of devenv.exe are waiting to finish network I/O".


    I am developing fully locally. I've tried disconnecting all network interfaces. All I see in Resource Monitor's TCP Connections tab are loopbacks.


    I would greatly appreciate ideas on how to troubleshoot further.

    Tuesday, March 08, 2016 1:00 AM

All replies

  • Hi Terrence Jones,

    What is the version of your Windows and Visual Studio?
    As you know, the latest is Visual Studio 2015 Update 1. Have you updated to Update 1?


    I'm searching some solutions, but in vain at the present time. I'll continue.

    Regards.
    Tuesday, March 08, 2016 2:22 AM
  • Hi,

    How about "devenv.exe /log"?

    In my case(Windows 10, Visual Studio 2015 Update 1), log file (ActivityLog.xml) is in 
    C:\Users\<account>\AppData\Roaming\Microsoft\VisualStudio\14.0

    refer to:
    /Log (devenv.exe)

    Regards.

    Tuesday, March 08, 2016 2:42 AM
  • Yes, sorry for the omission. I am running VS 2015 Enterprise SP1 under Windows 7 Enterprise SP1 x64.

    Additionally I'll mention that during the hang CPU and disk utilization are very low.

    Your help is appreciated.


    • Edited by Terrence Jones Tuesday, March 08, 2016 2:50 AM Additional information
    Tuesday, March 08, 2016 2:48 AM
  • I have tried logging. There is nothing shown immediately before or after the hang.
    Tuesday, March 08, 2016 2:49 AM
  • You mentioned "I am developing fully locally. I've tried disconnecting all network interfaces. All I see in Resource Monitor's TCP Connections tab are loopbacks.".
    I suppose you are connecting network under normal conditions.
    If "Flow Control" of your ethernet adapter is "Disabled", please change it to "Rx & Tx enabled".
    Tuesday, March 08, 2016 3:25 AM
  • I've checked my configuration. 

    My ethernet adapter is indeed set to Rx & Tx Enabled. My wireless, which I use exclusively has no such setting.

    To clarify, I should have said that I've tried turning off my wireless connection (via the hardware switch on my laptop), thus no internet connection. The problem persists in this state.

    Thanks for the idea.

    Tuesday, March 08, 2016 4:38 AM
  • I suppose that VS 2015 is wanting to connect to the Internet for searching new topics(News) or some updates and that your VS2015 issue would persist while your laptop has no internet connection.
    Tuesday, March 08, 2016 4:49 AM
  • Hmm... I don't see the connection. The delay happens always associated with some action on my part (save, open, document...). And also when I do have a strong network connection.
    Tuesday, March 08, 2016 4:54 AM
  • I suppose that VS 20xx is almost always wanting the Internet connection for the reason I've written.
    Does your issue happen while connecting to the Internet connection?
    Tuesday, March 08, 2016 5:13 AM
  • I see... I am typically connected to the internet; I disconnected the internet for troubleshooting.

    By fully locally I meant that the solution/project had no network dependency (TFS, NuGet, etc.)

    It really does't seem like it's trying to connect externally. As I mentioned, watching Resource Manager, I don't see any attempts at external connection. I looked at my firewall logs and didn't see any obvious issues.

    Thanks for the suggestions.

    Tuesday, March 08, 2016 6:11 AM
  • Hi Jones,

    >>I am developing fully locally. By fully locally I meant that the solution/project had no network dependency (TFS, NuGet, etc.)

    Since the application was developed fully locally. I don't think the cause is related to the Internet connection.

    Please restart your machine and disable anti-virus software and firewall then try it again.

    Also try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect the building progress (devenv/safemode)

    If still no help, in order to narrow down the cause of the issue. Please create a new same type project and write a simple code then try saving, building, loading solution and so on. Check whether the same issue occurred.

    1. If your Visual Studio 2015 still will be no responding. I suppose there is something wrong with your IDE. Please repair your VS2015 or install the VS2015 Update 1 then try it again.

    2. If it works well for the new created project. In this case, I think the cause is probably in your project itself. Please clean the .suo file in the project directory then try it again. If still no help, try to create a new solution then copy file into it then try it agian.

    Best Regards,

    Lake Xiao


    Wednesday, March 09, 2016 2:19 AM
    Moderator
  • Hello Lake

    As mentioned previously I've done all of your recommendations already including re-installing VS2015 and running in Safe Mode with no effect. I've disabled my Antivirus/Firewall as well.

    I see the same issues with new & empty Solutions/Projects.

    I am hoping somebody might provide some troubleshooting techniques (using procmon / procexp for example) to help understand why Visual Studio's wait chain shows network I/O while it's not responding.

    Thursday, March 10, 2016 2:01 AM
  • Hi Terrence Jones,

    I've found an article:
    Visual Studio 2015 and 2013: Known issues if Internet Explorer 10 or a later version is not installed

    Is IE 10 or a later version installed?  

    Regards.
    Thursday, March 10, 2016 3:51 AM
  • Yes, I have IE 11 installed. Thanks for the thought.
    Thursday, March 10, 2016 6:13 PM
  • Hi,

    I have no other choice to think there're something relating to network connection.
    So, I've search in Visual Studio 2015 and found:
    (They are all in [Tools] > [Options])

    [Environment] > [Extensions and Updates]


    [Environment] > [Startup]


    [NuGet Package Manager] > [General]


    How about disabling/unchecking the above options?
    (There might be more options that I've never found out.)

    Regards.
    Saturday, March 12, 2016 1:52 AM
  • Thanks for the response. These particular settings do not seem to be the cause.

    Again, I'm hoping to find some troubleshooting technique that will allow me to zero in on the cause, rather than blindly changing settings.

    What techniques can be used using Process Monitor / Process Explorer for example that can troubleshoot such a hang. I've tried using Process Explorer to monitor the call stack of threads that are being created or closed with the hang occurs without much luck.

    Thursday, March 17, 2016 12:09 AM
  • Hi,

    >>I see the same issues with new & empty Solutions/Projects.

    Since the same issue for the new empty project. I suppose there is something wrong with your VS installation.

    Please use  http://aka.ms/vscollect  to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to https://skydrive.live.com/  and share the link here.

    I want to check your logs for more details

    Best Regards,

    Lake Xiao

    Friday, March 18, 2016 1:20 AM
    Moderator
  • Hi Lake...

    Very good idea. I did at one point try to repair the install and the repair showed some errors (failed to find or repair package or something). I ended up uninstalling and reinstalling.

    I saw these hangs both on the original install and of course now.

    Here is the file you requested:

    https://goo.gl/0JHrIR

    Friday, March 18, 2016 5:48 PM
  • Hi Terrence Jones,

    I have checked the log you uploaded. And I found the following error in your installation logs:

    Applying execute package: VCRedistD14x64, action: Repair, path: <C:\ProgramData\Package Cache\77E9CECF-814E-3677-B7CF-5485DA3CDA6C\packages\vcRedistD14\VC_redist.x64.exe>, arguments: '"<C:\ProgramData\Package Cache\77E9CECF-814E-3677-B7CF-5485DA3CDA6C\packages\vcRedistD14\VC_redist.x64.exe>" /q /norestart /repair '

    [B40C:AD30][2016-02-29T10:24:25]e000: Error 0x80070666: Process returned error: 0x666

    [B40C:AD30][2016-02-29T10:24:25]e000: Error 0x80070666: Failed to execute EXE package.

    [CCF0:602C][2016-02-29T10:24:25]e000: Error 0x80070666: Failed to configure per-machine EXE package.

    I have did a research for the error message and I found the cause is related to the VC++ installation package is not installed correctly.

    In this case, I suggest you could uninstall the C++ component (VCRedistD14x64), and download a healthy one to repair again.

    https://www.microsoft.com/en-us/download/details.aspx?id=48145

    By the way, please take a look at this similar thread for your reference:

    https://social.msdn.microsoft.com/Forums/Windowsserver/en-US/3214b4de-08a0-4a83-9f81-6d2e7aae0e1c/installation-error?forum=vssetup

    Best Regards,

    Lake Xiao

    Monday, March 21, 2016 1:26 AM
    Moderator
  • I recall seeing errors regarding the VC ReDist package when I'd either installed VS2015 or when I attempted to repair it. I had ended up installing it manually.

    In any case, I've again uninstalled and reinstalled VCRedistD14x64. Time will tell if it improves my situation with VS hanging.

    Also, in my original post I mentioned that Resource Monitor always reports on VS' wait chain with: "One or more threads of devenv.exe are waiting to finish network I/O". I've since noticed that Resource Monitor always says this about Visual Studio, even when it's not hanging.

    I don't see this on other PCs. The calls stack of the thread that's waiting is below. I don't see much in there that would tell me what VS is waiting on. Also, because it is always showing "waiting to finish network I/O" I don't know if that is related to my hangs.

    I will be out of town for a few days and will return to this discussion then.

    ntoskrnl.exe!KeWaitForMultipleObjects+0xc0a
    ntoskrnl.exe!KeAcquireSpinLockAtDpcLevel+0x712
    ntoskrnl.exe!KeWaitForSingleObject+0x19f
    ntoskrnl.exe!PoStartNextPowerIrp+0xba4
    ntoskrnl.exe!PoStartNextPowerIrp+0x184d
    ntoskrnl.exe!KeAcquireSpinLockAtDpcLevel+0x91d
    ntoskrnl.exe!KeWaitForSingleObject+0x19f
    ntoskrnl.exe!NtWaitForSingleObject+0xde
    ntoskrnl.exe!KeSynchronizeExecution+0x3a23
    wow64cpu.dll!TurboDispatchJumpAddressEnd+0x6c0
    wow64cpu.dll!TurboDispatchJumpAddressEnd+0x4a8
    wow64.dll!Wow64SystemServiceEx+0x1ce
    wow64.dll!Wow64LdrpInitialize+0x42a
    ntdll.dll!TpAlpcRegisterCompletionList+0x7aec
    ntdll.dll!LdrInitializeThunk+0xe
    ntdll.dll!ZwWaitForSingleObject+0x15
    mswsock.dll!MigrateWinsockConfiguration+0x52a6
    WS2_32.dll!recvfrom+0x79
    System.ni.dll+0x5d3692
    System.ni.dll+0x617372
    System.ni.dll+0x69612e
    clr.dll+0x1396
    clr.dll+0x291f
    clr.dll+0x9aff
    clr.dll!GetMetaDataPublicInterfaceFromInternal+0x5d81
    clr.dll!PreBindAssembly+0x9653
    clr.dll!PreBindAssembly+0x96bd
    clr.dll!PreBindAssembly+0x978a
    clr.dll!PreBindAssembly+0x9805
    clr.dll!GetMetaDataPublicInterfaceFromInternal+0x5ba8
    clr.dll!GetCLRFunction+0x107dc
    ntdll.dll!RtlInitializeExceptionChain+0x63
    ntdll.dll!RtlInitializeExceptionChain+0x36

    Tuesday, March 22, 2016 3:23 PM
  • Hi Terrence Jones,

    From the installation log, I found the VC ReDist package was not installed completely.

    If you have reinstalled the VC ReDist package  and still has the same issue. I suppose this might be related to the performance of your PC.

    Please restart your machine and close other third party program and disable the anti-virus software and run your VS in safe mode then try it again.

    Best Regards,

    Lake Xiao

    Wednesday, March 23, 2016 1:14 AM
    Moderator