locked
Error when removing a CodedUITest association in MTM RRS feed

  • Question

  • Hi,

     

      When I try to remove and associated automation from an acceptance test I got the following error:

    ------------------------------------------------------------------------------------------------------------------------

    This work item cannot be saved

    The field 'automation status' contains the value 'Automated' that is not in the list of supported values.

    ------------------------------------------------------------------------------------------------------------------------

    At this point this is impossible for me to remove the association. Any idea on how to fix this?

    thank you

     


    Yan Badeaux Spécialiste en Assurance Qualité Quality Assurance Specialist Fortsum solutions d'affaires
    Friday, March 11, 2011 4:19 PM

Answers

  • Ok we found the problem. We weren’t handling this field at all in the UI(visual or MTM) so the field was not present at all, but when I was associating a test method with the acceptance test, the value was set automatically to automated... Therefore when I was removing the association the value was not reset and was still at automated which is invalid. We added the field in our supported field so I can set it back to his original value manually and fix the problem.


    Yan Badeaux Spécialiste en Assurance Qualité Quality Assurance Specialist Fortsum solutions d'affaires
    • Marked as answer by YanBadeaux Monday, March 14, 2011 7:39 PM
    Monday, March 14, 2011 7:39 PM

All replies

  • you have to set the field 'automatin status' to something differnent than 'automated' before saving the test case
    http://www.ClemensReijnen.nl
    Friday, March 11, 2011 9:22 PM
  • I can't find this field anywhere, is it possible that we removed it?
    Yan Badeaux Spécialiste en Assurance Qualité Quality Assurance Specialist Fortsum solutions d'affaires
    Monday, March 14, 2011 12:06 PM
  • Ok we found the problem. We weren’t handling this field at all in the UI(visual or MTM) so the field was not present at all, but when I was associating a test method with the acceptance test, the value was set automatically to automated... Therefore when I was removing the association the value was not reset and was still at automated which is invalid. We added the field in our supported field so I can set it back to his original value manually and fix the problem.


    Yan Badeaux Spécialiste en Assurance Qualité Quality Assurance Specialist Fortsum solutions d'affaires
    • Marked as answer by YanBadeaux Monday, March 14, 2011 7:39 PM
    Monday, March 14, 2011 7:39 PM
  • Hi,

    When is this problem expected to get resolved?

    Any current workaround for this?

    Nitin


    NK

    Thursday, February 16, 2012 12:44 PM