locked
On which servers the solutions should/will be deployed RRS feed

  • Question

  • Lets say i have two web and two app servers . Am installing a wsp using ps.

    I wanna know how SP decides on which servers the gav and feature files should go to ?

    or in other words when you deploy the solution on which servers the solution will be deployed.

    is there a diff in which server the soln will be deployed to if its a webpart or a timer job ?

    what services on servers determines on which server the solution should go to  >?

    Does the soln get installed where the Central administration is running ?


    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 4, 2015 5:25 PM

Answers

All replies

  • WSPs will be deployed to any server that is running Microsoft SharePoint Foundation Web Application. 

    sachin

    Friday, December 4, 2015 5:35 PM
  • Thought so the same but in my case I have the service turned off on the app servers but the deployment stratus shows its deployed on app server as well, only on one app server. Not sure why would it do that

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 4, 2015 5:53 PM
  • Does App server have central admin running?

    sachin

    Friday, December 4, 2015 6:21 PM
  • Yes , App server it is running the CA

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 4, 2015 6:25 PM
  • WSP also gets deployed to server where CA is running. 

    sachin

    Friday, December 4, 2015 6:33 PM
  • even if the "Microsoft SharePoint Foundation Web Application" is not running on that server?

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 4, 2015 6:49 PM
  • Yes. I have seen same behavior in my farm too.

    sachin

    Friday, December 4, 2015 7:11 PM
  • so if you have "Central Administration" service running on app01 and app02 but MS foundation web application being stopped on both these servers,

     MS foundation web application service started on web01 and web02 , "Central Admin" stopped on same web 01 and web02.

    so if now i deploy a solution it ll go to web01,web02,app01,app02 ?


    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 4, 2015 7:27 PM
  • Yes. I am thinking Central admin web.config file needs to be updated with safe control or assembly type for these wsp , that is why they get deployed there too. 

    sachin

    Friday, December 4, 2015 7:29 PM