locked
Crystal Reports - Picture does not display RRS feed

  • Question

  • User1023395591 posted

    I am using Visual Studio 2010 Professional, with Crystal Reports for .NET Framework 4.0. I have reports with company logo image, using Insert/Picture. When running thru VS from development environment, logo image displays when running the reports. When I move the reports to the production environment, the images do not display, just a red 'X' and the text "Image" next to it in a grey box. I have been under the understanding that using the Insert/Picture actually embeds the image into the report, but this does not seem to be working properly. I moved the image to a directory under the prduction area, and inserted the pics from there, thinking it may be using a path, and this path would be found when running from production, but this does not work either. Please help!

    Tuesday, May 31, 2011 10:08 AM

Answers

All replies

  • User1196771204 posted

    Hi tullygarvan,

    may I please know first how do you host your crystal report project? Do you host it on your local PC or on a remote server? Based on the error message you mentioned, it seems that your Crystal Report is not properly setup.

    If you host your Crystal Report on a remote server, you need to contact your hosting provider to check the CR version, assemblies installed on the server. Please also make sure they check for the permission and FULL TRUST setting on your project/website. If they still cannot help you, you can consider moving your site to another host that supports Crystal Report 2010. One that I can recommend is asphostcentral.com and they have supported Crystal Report for VS 2010.

    Please mark this post as an asnwer if it helps you. Good luck!

    Wednesday, June 1, 2011 10:42 PM
  • User1023395591 posted

    The production website is hosted on the same server as I develop on, in a different directory. When in VS with the development copy, the logo displays using the report Preview. And when I run the report in VS from the website using the debugger (development copy), the logo displays. But when I run the report from the production website, the logo does not display. It is however included in a PDF when exported. So seems to be an issue with the CrystalReportViewer from the production site (directory). Any ideas? Thanks!

    Tuesday, June 7, 2011 3:12 PM
  • User-1802908944 posted

    This will help you a lot

    Use this: http://natrajt.blogspot.com/2008/06/dynamic-images-at-runtime-in-crystal.html

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 9, 2011 12:34 PM